summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/kdeutils/debian/cdbs/debian-qt-kde.mk
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-11-16 03:48:08 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-11-16 03:51:41 +0100
commitd58d93e0227ee339a180c2ee71e569cfa6dc4121 (patch)
treeebfba7bbe7f454b9e58a948799e436c937e0c6a2 /ubuntu/maverick/kdeutils/debian/cdbs/debian-qt-kde.mk
parentae53bea11a5561b6a71541911e3dcf0ee1e7ffc2 (diff)
downloadtde-packaging-d58d93e0227ee339a180c2ee71e569cfa6dc4121.tar.gz
tde-packaging-d58d93e0227ee339a180c2ee71e569cfa6dc4121.zip
Fix tdeutils build issues on Debian and Ubuntu
Cdbs files modified to support both automake and cmake Removed unnecessary files installed into doc Include files moved to default location (cherry picked from commit e747ba9c24732028ce543f6885900dbe513a4ffd)
Diffstat (limited to 'ubuntu/maverick/kdeutils/debian/cdbs/debian-qt-kde.mk')
-rw-r--r--ubuntu/maverick/kdeutils/debian/cdbs/debian-qt-kde.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/ubuntu/maverick/kdeutils/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/kdeutils/debian/cdbs/debian-qt-kde.mk
index d135c4257..f8b76cb04 100644
--- a/ubuntu/maverick/kdeutils/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/maverick/kdeutils/debian/cdbs/debian-qt-kde.mk
@@ -10,9 +10,11 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -75,11 +77,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
if test -e debian/$(cdbs_curpkg).lintian; then \
install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/opt/trinity/share/lintian/overrides/$(cdbs_curpkg); \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
fi
if test -e debian/$(cdbs_curpkg).presubj; then \
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/opt/trinity/share/bug/$(cdbs_curpkg)/presubj; \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
@@ -96,6 +98,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -104,6 +107,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif