summaryrefslogtreecommitdiffstats
path: root/arch/3.5.13/trinity-extras/trinity-konversation/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/3.5.13/trinity-extras/trinity-konversation/PKGBUILD')
-rw-r--r--arch/3.5.13/trinity-extras/trinity-konversation/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/arch/3.5.13/trinity-extras/trinity-konversation/PKGBUILD b/arch/3.5.13/trinity-extras/trinity-konversation/PKGBUILD
new file mode 100644
index 000000000..e4e63422a
--- /dev/null
+++ b/arch/3.5.13/trinity-extras/trinity-konversation/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+# Maintainer: David C. Rankin <drankinatty@gmail.com>
+#
+# All modifications and uses of this file are licensed under
+# the software for which this file was made for, should the software
+# be under an Open Source License, at least version 1.9, defined
+# by the Open Source Initiative. In other cases, this file is automatically
+# released to the Public Domain.
+#
+
+pkgname=trinity-konversation
+pkgver=3513
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://www.kde.org'
+license=('GPL')
+groups=('trinity')
+pkgdesc="Trinity - Konversation IRC client"
+depends=('trinity-kdebase')
+makedepends=('pkgconfig' 'cmake' 'imake')
+options=('libtool' '!strip')
+source=(http://mirror.its.uidaho.edu/pub/trinity/releases/3.5.13/applications/konversation-3.5.13.tar.gz)
+md5sums=('0f0e0415dad4c19bc885c9addadf4026')
+
+build() {
+
+ msg "Setting PATH, CMAKE and Trinity Environment variables"
+ export CMAKE_PREFIX_PATH=/opt/qt:/opt/trinity
+ export CMAKE_INCLUDE_PATH=/opt/qt/include:/opt/qt/include/tqt:/usr/include/dbus-1.0:/opt/trinity/include:/opt/trinity/include/libkrandr
+ export LD_LIBRARY_PATH=/opt/trinity/lib:/opt/trinity/lib/kde3:$LD_LIBRARY_PATH
+ export PKG_CONFIG_PATH=:/opt/trinity/lib/pkgconfig:/opt/qt/lib/pkgconfig
+
+ trinity_prefix="/opt/trinity"
+
+ msg "Starting cmake..."
+
+ cd "$srcdir/applications/konversation"
+ make -f admin/Makefile.common
+ ./configure --with-qt-dir=/opt/qt/ --prefix=/opt/trinity
+ make
+}
+
+package() {
+ msg "Packaging - $pkgname-$pkgver"
+# cd ${srcdir}/${_svnmod}
+ cd ${srcdir}/build
+
+ make DESTDIR="$pkgdir/" install
+
+# rm -r ${srcdir}/${_svnmod}
+}