summaryrefslogtreecommitdiffstats
path: root/arch/tde-extra/tde-amarok/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-extra/tde-amarok/PKGBUILD')
-rw-r--r--arch/tde-extra/tde-amarok/PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/arch/tde-extra/tde-amarok/PKGBUILD b/arch/tde-extra/tde-amarok/PKGBUILD
index d26358250..b87b39775 100644
--- a/arch/tde-extra/tde-amarok/PKGBUILD
+++ b/arch/tde-extra/tde-amarok/PKGBUILD
@@ -1,40 +1,47 @@
# Contributor: e1z0 <justinas at eofnet dot lt>
pkgname=tde-amarok
-pkgver=14.0.5
+pkgver=14.0.10
pkgrel=1
pkgdesc="TDE Amarok"
arch=('i686' 'x86_64')
-url='http://scm.trinitydesktop.org/scm/git/applications/amarok'
+url='https://scm.trinitydesktop.org/scm/git/applications/amarok'
license=('GPL')
groups=('tde-extra')
-depends=('tde-tdebase' 'taglib')
+depends=('tde-tdebase' 'taglib' 'xine-lib')
makedepends=('pkgconfig' 'cmake')
#provides=('tde-amarok')
#conflicts=('tde-amarok')
#replaces=('tde-amarok')
options=('staticlibs' 'libtool' '!strip')
-source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/applications/amarok-R${pkgver}.tar.bz2")
-md5sums=('0351b0d4ee54ae266e2a3ec47cd3accf')
+source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/applications/amarok-trinity-${pkgver}.tar.xz")
+md5sums=('fab4ed783d4027711e4aaca098bb04b1')
# install=''
+[ -n "$TDEDIR" ] || TDEDIR=/opt/trinity
+
build() {
- ## Generate config files and update with autoreconf
- cd ${srcdir}/applications/${pkgname#*-}
+ cd $srcdir
+ msg "Creating out-of-source build directory: ${srcdir}/build"
+ mkdir -p build
+ cd build
- msg "Running make -f admin/Makefile.common ...."
- make -f admin/Makefile.common
+ export PKG_CONFIG_PATH=${TDEDIR}/lib/pkgconfig:${PKG_CONFIG_PATH}
- ## configure
- msg "Configuring - ${pkgname}..."
+ msg "Starting cmake..."
+ cmake ${srcdir}/${pkgname#*-}-trinity-${pkgver} \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DCMAKE_INSTALL_PREFIX=${TDEDIR} \
+ -DBUILD_ALL=ON \
+ -DWITH_EMBEDDED_SQLITE=ON \
+ -DWITH_OPENGL=ON
- ./configure --prefix=${TDEDIR}
- make $NUMJOBS
+ msg "Building - ${pkgname#*-}..."
+ make $NUMJOBS
}
package() {
msg "Packaging - $pkgname-$pkgver"
- cd ${srcdir}/applications/${pkgname#*-}
-
+ cd ${srcdir}/build
make -j1 DESTDIR="${pkgdir}" install
}