summaryrefslogtreecommitdiffstats
path: root/arch/tde-extra/tde-tdeaddons/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-extra/tde-tdeaddons/PKGBUILD')
-rw-r--r--arch/tde-extra/tde-tdeaddons/PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/arch/tde-extra/tde-tdeaddons/PKGBUILD b/arch/tde-extra/tde-tdeaddons/PKGBUILD
index 8a16ac123..798aaaf72 100644
--- a/arch/tde-extra/tde-tdeaddons/PKGBUILD
+++ b/arch/tde-extra/tde-tdeaddons/PKGBUILD
@@ -1,10 +1,10 @@
# Contributor: e1z0 <justinas at eofnet dot lt>
pkgname=tde-tdeaddons
-pkgver=14.0.5
+pkgver=14.0.10
pkgrel=1
arch=('i686' 'x86_64')
-url='http://scm.trinitydesktop.org/scm/git/tdeaddons'
+url='https://scm.trinitydesktop.org/scm/git/tdeaddons'
license=('GPL')
groups=('tde-extra')
pkgdesc="Trinity Desktop Addons"
@@ -14,21 +14,24 @@ provides=('tdeaddons')
conflicts=('trinity-tdeaddons' 'trinity-kdeaddons')
replaces=('trinity-tdeaddons')
options=('staticlibs' 'libtool' '!strip')
-source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/tdeaddons-R${pkgver}.tar.bz2")
-md5sums=('b730d4d465d867755a19f77e6efc9e88')
+source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/core/tdeaddons-trinity-${pkgver}.tar.xz")
+md5sums=('27557921bf86569042c72d597b87c877')
# install=''
+[ -n "$TDEDIR" ] || TDEDIR=/opt/trinity
+
build() {
cd $srcdir
msg "Creating out-of-source build directory: ${srcdir}/build"
mkdir -p build
cd build
+ export PKG_CONFIG_PATH=${TDEDIR}/lib/pkgconfig:${PKG_CONFIG_PATH}
+
msg "Starting cmake..."
- cmake ${srcdir}/${pkgname#*-} \
+ cmake ${srcdir}/${pkgname#*-}-trinity-${pkgver} \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_INSTALL_PREFIX=$TDEDIR \
- -DWITH_SPEEX=ON \
-DWITH_ARTS=ON \
-DBUILD_ALL=ON