summaryrefslogtreecommitdiffstats
path: root/dilos/dependencies/tqt3/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/dependencies/tqt3/debian/rules')
-rwxr-xr-xdilos/dependencies/tqt3/debian/rules14
1 files changed, 1 insertions, 13 deletions
diff --git a/dilos/dependencies/tqt3/debian/rules b/dilos/dependencies/tqt3/debian/rules
index 910bfb64a..c031285c2 100755
--- a/dilos/dependencies/tqt3/debian/rules
+++ b/dilos/dependencies/tqt3/debian/rules
@@ -188,10 +188,6 @@ libqt-thread-stamp: post-patches
cd tools/designer/tools/tqtconv2ui && $(MAKE)
cp bin/tqtconv2ui $(TMP_INSTALL)/usr/bin/tqtconv2ui
- # build tqvfb
- cd tools/tqvfb/ && $(MAKE)
- cp tools/tqvfb/tqvfb $(TMP_INSTALL)/usr/bin/tqvfb
-
# install qmake.cache file
install -d $(P_QTMTDEV)/usr/share/tqt3/
cat .qmake.cache | sed "s#$(QTDIR)#/usr/share/tqt3#g" > $(P_QTMTDEV)/usr/share/tqt3/.qmake.cache
@@ -218,7 +214,7 @@ clean::
if [ -f "src/Makefile" ]; then \
$(MAKE) -C src clean; $(MAKE) -C plugins/src distclean; $(MAKE) -C tools distclean; \
- $(MAKE) -C tools/maketqpf distclean; $(MAKE) -C tools/qconfig distclean; $(MAKE) -C tools/tqvfb distclean; \
+ $(MAKE) -C tools/qconfig distclean; \
$(MAKE) -C tools/msg2tqm distclean; $(MAKE) -C tools/tqtmergetr distclean; $(MAKE) -C tools/qembed distclean; \
$(MAKE) -C tools/designer/tools/tqtconv2ui distclean; $(MAKE) -C tools/designer/tools/tqtcreatecw distclean; \
$(MAKE) -C tools/designer/plugins/glade distclean; $(MAKE) -C tools/designer/plugins/qglwidget distclean; \
@@ -409,11 +405,6 @@ binary-arch: build install
cp `pwd`/tools/designer/editor/*.h $(P_APPSDEV)/usr/include/tqt3/
rm -rf `pwd`/debian/tqt3-apps-dev/usr/include/tqt3/preferences.ui.h
- ## tqvfb package
- install -m644 -D `pwd`/tools/tqvfb/pda.skin `pwd`/debian/tqt3-dev-tools-embedded/etc/tqt3/tqvfb/pda.skin
- install -m644 -D `pwd`/tools/tqvfb/pda_down.png `pwd`/debian/tqt3-dev-tools-embedded/usr/share/tqvfb/pda_down.png
- install -m644 -D `pwd`/tools/tqvfb/pda_up.png `pwd`/debian/tqt3-dev-tools-embedded/usr/share/tqvfb/pda_up.png
-
# remove utterly ugle symlink
rm -rf `pwd`/debian/tqt3-dev-tools//usr/share/tqt3/mkspecs/linux-g++/linux-g++
@@ -509,9 +500,6 @@ binary-arch: build install
# fix shlibdeps madness
for a in `find debian/ -name '*.substvars'`; do cat "$$a" | sed 's/, xlibs (>> 4.1.0)//g' > "$$a".new && mv "$$a.new" "$$a"; done
- # fix conffiles file for tqt3-dev-tools-embedded
- echo "/etc/tqt3/tqvfb/pda.skin" > `pwd`/debian/tqt3-dev-tools-embedded/DEBIAN/conffiles
-
dh_gencontrol -a $(IBASE)
dh_md5sums -a $(IBASE)
dh_builddeb -a $(IBASE) $(DEB_DH_BUILDDEB_ARGS)