summaryrefslogtreecommitdiffstats
path: root/redhat/applications/bibletime/bibletime-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/bibletime/bibletime-14.0.0.spec')
-rw-r--r--redhat/applications/bibletime/bibletime-14.0.0.spec101
1 files changed, 64 insertions, 37 deletions
diff --git a/redhat/applications/bibletime/bibletime-14.0.0.spec b/redhat/applications/bibletime/bibletime-14.0.0.spec
index f55298ab2..c6a0991a1 100644
--- a/redhat/applications/bibletime/bibletime-14.0.0.spec
+++ b/redhat/applications/bibletime/bibletime-14.0.0.spec
@@ -1,55 +1,91 @@
-# Default version for this component
-%define tde_pkg bibletime
-%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
+#
+# spec file for package bibletime (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# Required for PCLinuxOS: removes the ldflag '--no-undefined'
+%if 0%{?pclinuxos}
+%define _disable_ld_no_undefined 1
%endif
-# TDE specific building variables
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.0
+%endif
+%define tde_pkg bibletime
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
Name: trinity-%{tde_pkg}
-Summary: A bible study tool for Trinity
+Epoch: %{tde_epoch}
Version: 1.6.6.0
-Release: %{?!preversion:8}%{?preversion:7_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: A bible study tool for Trinity
Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
-BuildRequires: desktop-file-utils
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: libtool
+BuildRequires: desktop-file-utils
BuildRequires: gettext
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# BOOST support
+BuildRequires: boost-devel
+
# Requires: clucene
-%if 0%{?fedora} || 0%{?suse_version}
+%if 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 6
BuildRequires: clucene-core-devel
%endif
%if 0%{?mgaversion} || 0%{?mdkversion}
@@ -67,17 +103,19 @@ BibleTime provides easy handling of digitized texts (Bibles, commentaries
and lexicons) and powerful features to work with these texts (search in
texts, write own notes, save, print etc.).
+##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -118,22 +156,13 @@ export PATH="%{tde_bindir}:${PATH}"
%__chmod 644 %{buildroot}%{tde_datadir}/apps/bibletime/bibletimeui.rc
%__chmod 644 %{buildroot}%{tde_datadir}/apps/bibletime/tips
+echo "OnlyShowIn=TDE;" >>"%{?buildroot}%{tde_datadir}/applications/bibletime.desktop"
+
%clean
%__rm -rf %{buildroot}
-%post
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-update-desktop-database %{tde_datadir}/applications -q &> /dev/null
-
-%postun
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-update-desktop-database %{tde_datadir}/applications -q &> /dev/null
-
-
%files
%defattr(-,root,root,-)
%{tde_bindir}/bibletime
@@ -145,5 +174,3 @@ update-desktop-database %{tde_datadir}/applications -q &> /dev/null
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 1.6.6.0-6
-- Initial release for TDE 14.0.0