summaryrefslogtreecommitdiffstats
path: root/redhat/applications/k3b-i18n/k3b-i18n-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/k3b-i18n/k3b-i18n-14.0.0.spec')
-rw-r--r--redhat/applications/k3b-i18n/k3b-i18n-14.0.0.spec121
1 files changed, 70 insertions, 51 deletions
diff --git a/redhat/applications/k3b-i18n/k3b-i18n-14.0.0.spec b/redhat/applications/k3b-i18n/k3b-i18n-14.0.0.spec
index 908c9be85..c641a739f 100644
--- a/redhat/applications/k3b-i18n/k3b-i18n-14.0.0.spec
+++ b/redhat/applications/k3b-i18n/k3b-i18n-14.0.0.spec
@@ -1,38 +1,60 @@
-# Default version for this component
-%define tde_pkg k3n-i18n
+#
+# spec file for package k3b-i18n (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg k3b-i18n
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-Name: trinity-k3b-i18n
-Summary: Internationalization support for TDE [Trinity]
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
Version: 1.0.5
-Release: %{?!preversion:5}%{?preversion:4_%{preversion}}%{?dist}%{?_variant}
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Internationalization support for TDE [Trinity]
+Group: Applications/Archiving
URL: http://www.trinitydesktop.org/
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
BuildArch: noarch
# Speed build options
@@ -40,22 +62,18 @@ BuildArch: noarch
%define __spec_install_post %{nil}
AutoReq: no
-Prefix: %{_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Group: Applications/Archiving
-License: GPLv2+
-
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
BuildRequires: gettext
+BuildRequires: cmake
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
Requires(post): coreutils
Requires(postun): coreutils
@@ -328,39 +346,42 @@ This package contains the Ukrainian translations for K3B.
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f "admin/Makefile.common"
-
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-./configure \
- --prefix=%{tde_prefix} \
- --exec-prefix=%{tde_prefix} \
- --bindir=%{tde_bindir} \
- --datadir=%{tde_datadir} \
- --docdir=%{tde_tdedocdir} \
- --includedir=%{tde_tdeincludedir} \
- --libdir=%{tde_libdir} \
- --mandir=%{tde_mandir} \
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_NO_BUILTIN_CHRPATH=ON \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DCMAKE_PROGRAM_PATH="%{tde_bindir}" \
+ -DWITH_GCC_VISIBILITY=ON \
\
- --disable-dependency-tracking \
- --disable-debug \
- --enable-new-ldflags \
- --enable-final \
- --enable-closure \
- --enable-rpath \
- --disable-gcc-hidden-visibility
+ -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
+ -DBIN_INSTALL_DIR=%{tde_bindir} \
+ -DCONFIG_INSTALL_DIR="%{tde_confdir}" \
+ -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
+ ..
-%__make %{?_smp_mflags}
+%__make %{?_smp_mflags} || %__make
%install
+export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot}
+%__make install DESTDIR=%{?buildroot} -C build
%__rm -rf %{buildroot}%{tde_datadir}/locale/af
%__rm -rf %{buildroot}%{tde_datadir}/locale/ar
@@ -409,5 +430,3 @@ export PATH="%{tde_bindir}:${PATH}"
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 1.0.5-4
-- Initial release for TDE 14.0.0