summaryrefslogtreecommitdiffstats
path: root/redhat/applications/k3b/k3b-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/k3b/k3b-14.0.0.spec')
-rw-r--r--redhat/applications/k3b/k3b-14.0.0.spec241
1 files changed, 123 insertions, 118 deletions
diff --git a/redhat/applications/k3b/k3b-14.0.0.spec b/redhat/applications/k3b/k3b-14.0.0.spec
index 8e2310afb..5bc2c6e88 100644
--- a/redhat/applications/k3b/k3b-14.0.0.spec
+++ b/redhat/applications/k3b/k3b-14.0.0.spec
@@ -1,74 +1,116 @@
-# Default version for this component
-%define tde_pkg k3b
+#
+# spec file for package k3b (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg k3b
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
%define tde_bindir %{tde_prefix}/bin
+%define tde_confdir %{_sysconfdir}/trinity
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
Name: trinity-%{tde_pkg}
-Summary: CD/DVD burning application
-Epoch: 1
+Epoch: %{tde_epoch}
Version: 1.0.5
-Release: %{?!preversion:2}%{?preversion:1_%{preversion}}%{?dist}%{?_variant}
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: CD/DVD burning application
+Group: Applications/Archiving
URL: http://www.trinitydesktop.org/
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Group: Applications/Archiving
-License: GPLv2+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-Source2: k3brc
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-# Legacy RedHat / Fedora patches
-# manual bufsize (upstream?)
-Patch4: k3b-1.0.4-manualbufsize.patch
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+Source1: %{name}-rpmlintrc
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
+BuildRequires: cmake
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
BuildRequires: alsa-lib-devel
BuildRequires: audiofile-devel
BuildRequires: gettext
BuildRequires: libmpcdec-devel
-BuildRequires: libmusicbrainz-devel
BuildRequires: libvorbis-devel
BuildRequires: taglib-devel
BuildRequires: zlib-devel
+# IDN support
+BuildRequires: libidn-devel
+
+# GAMIN support
+# Not on openSUSE.
+%if 0%{?rhel} || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
+%define with_gamin 1
+BuildRequires: gamin-devel
+%endif
+
+# OPENSSL support
+BuildRequires: openssl-devel
+
+# ACL support
+BuildRequires: libacl-devel
+
+# ATTR support
+BuildRequires: libattr-devel
+
Requires(post): coreutils
Requires(postun): coreutils
Requires: %{name}-libs = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: %{name}-common = %{?epoch:%{epoch}:}%{version}-%{release}
-%if 0%{?suse_version} >= 1310
+%if 0%{?suse_version} >= 1310 && 0%{?suse_version} < 1500
Requires: wodim
REquires: genisoimage
%else
@@ -82,6 +124,17 @@ Requires: dvd+rw-tools
Requires: cdrdao
%endif
+# UDEV support
+%if 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion} || 0%{?suse_version} || 0%{?rhel} >= 6
+BuildRequires: libudev-devel
+%endif
+
+# HAL support
+%if 0%{?rhel} == 5
+%define with_hal 1
+BuildRequires: hal-devel
+%endif
+
# DBUS support
# TQT bindings not available for RHEL4
%if 0%{?rhel} == 4
@@ -106,14 +159,12 @@ BuildRequires: libsamplerate-devel
%endif
# DVDREAD support
-%if 0%{?mdkversion} || 0%{?mgaversion} || 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 4
%define with_dvdread 1
%if 0%{?mdkversion} || 0%{?mgaversion}
BuildRequires: %{_lib}dvdread-devel
%else
BuildRequires: libdvdread-devel
%endif
-%endif
# FLAC support
%if 0%{?mgaversion} || 0%{?mdkversion}
@@ -129,6 +180,7 @@ BuildRequires: flac-devel
%endif
# MAD support
+%ifarch %{ix86} x86_64
%if 0%{?mdkversion} || 0%{?mgaversion} || 0%{?fedora} || 0%{?suse_version} || 0%{?rhel}
%define with_libmad 1
%if 0%{?mdkversion} || 0%{?mgaversion}
@@ -138,15 +190,21 @@ BuildRequires: %{_lib}mad-devel
BuildRequires: libmad-devel
%endif
%endif
+%endif
# LAME support
+%if 0%{?opensuse_bs} == 0
%if 0%{?mdkversion} || 0%{?mgaversion} || 0%{?fedora} || 0%{?suse_version} || 0%{?rhel}
%define with_lame 1
%if 0%{?mgaversion} || 0%{?mdkversion}
%if 0%{?pclinuxos}
BuildRequires: liblame-devel
%else
-BuildRequires: %{_lib}lame-devel
+%if 0%{?mgaversion} >= 6
+BuildRequires: %{_lib}mp3lame-devel
+%else
+BuildRequires: %{_lib}lame-devel
+%endif
%endif
%endif
%if 0%{?suse_version}
@@ -156,6 +214,7 @@ BuildRequires: libmp3lame-devel
BuildRequires: lame-devel
%endif
%endif
+%endif
# FFMPEG support
%if 0%{?mdkversion} || 0%{?mgaversion} || 0%{?fedora} || 0%{?suse_version} || 0%{?rhel}
@@ -231,7 +290,6 @@ BuildArch: noarch
%defattr(-,root,root,-)
%{tde_tdeappdir}/k3b.desktop
%{tde_datadir}/applnk/.hidden/k3b-cue.desktop
-%{tde_datadir}/applnk/.hidden/k3b-iso.desktop
%{tde_datadir}/apps/k3b/
%{tde_datadir}/apps/konqsidebartng/virtual_folders/services/videodvd.desktop
%{tde_datadir}/apps/konqueror/servicemenus/k3b_audiocd_rip.desktop
@@ -240,7 +298,6 @@ BuildArch: noarch
%{tde_datadir}/apps/konqueror/servicemenus/k3b_handle_empty_cd.desktop
%{tde_datadir}/apps/konqueror/servicemenus/k3b_handle_empty_dvd.desktop
%{tde_datadir}/apps/konqueror/servicemenus/k3b_videodvd_rip.desktop
-%{tde_datadir}/config/k3brc
%{tde_datadir}/mimelnk/application/x-k3b.desktop
%{tde_datadir}/icons/hicolor/*/apps/k3b.png
%{tde_datadir}/services/tdefile_k3b.desktop
@@ -250,20 +307,6 @@ BuildArch: noarch
%{tde_datadir}/sounds/k3b_wait_media1.wav
%{tde_tdedocdir}/HTML/en/tdeioslave/videodvd/
-%post common
-touch --no-create %{tde_datadir}/icons/hicolor ||:
-
-%postun common
-if [ $1 -eq 0 ] ; then
- touch --no-create %{tde_datadir}/icons/hicolor &> /dev/null
- gtk-update-icon-cache %{tde_datadir}/icons/hicolor &> /dev/null || :
- update-desktop-database %{tde_appdir} -q &> /dev/null
-fi
-
-%posttrans common
-gtk-update-icon-cache %{tde_datadir}/icons/hicolor &> /dev/null || :
-update-desktop-database %{tde_appdir} -q &> /dev/null
-
##########
%package libs
@@ -281,12 +324,6 @@ Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
%{tde_libdir}/libk3bdevice.so.5
%{tde_libdir}/libk3bdevice.so.5.0.0
-%post libs
-/sbin/ldconfig
-
-%postun libs
-/sbin/ldconfig
-
##########
%package devel
@@ -303,12 +340,6 @@ Requires: %{name}-libs = %{?epoch:%{epoch}:}%{version}-%{release}
%{tde_libdir}/libk3b.so
%{tde_libdir}/libk3bdevice.so
-%post devel
-/sbin/ldconfig
-
-%postun devel
-/sbin/ldconfig
-
##########
%if 0%{?with_libmad}
@@ -375,7 +406,7 @@ and a generic audio and video file converter.
##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
@@ -385,74 +416,50 @@ and a generic audio and video file converter.
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-# set in k3brc too
-%patch4 -p1 -b .manualbufsize
-
-%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f "admin/Makefile.common"
-
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig:${PKG_CONFIG_PATH}"
-# FFMPEG trick ...
-if [ -d /usr/include/ffmpeg ]; then
- export CXXFLAGS="${RPM_OPT_FLAGS} -I/usr/include/ffmpeg"
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
fi
-# Notice: extra-includes is required to find arts headers
-%configure \
- --prefix=%{tde_prefix} \
- --exec-prefix=%{tde_prefix} \
- --bindir=%{tde_bindir} \
- --datadir=%{tde_datadir} \
- --libdir=%{tde_libdir} \
- --mandir=%{tde_mandir} \
- --includedir=%{tde_tdeincludedir} \
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_NO_BUILTIN_CHRPATH=ON \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DCMAKE_PROGRAM_PATH="%{tde_bindir}" \
+ -DWITH_GCC_VISIBILITY=OFF \
\
- --disable-dependency-tracking \
- --disable-debug \
- --enable-new-ldflags \
- --enable-final \
- --enable-closure \
- --enable-rpath \
- --disable-gcc-hidden-visibility \
+ -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
+ -DBIN_INSTALL_DIR=%{tde_bindir} \
+ -DCONFIG_INSTALL_DIR="%{tde_confdir}" \
+ -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
\
- --with-extra-includes=%{tde_includedir} \
- \
- --with-k3bsetup=no \
- --without-cdrecord-suid-root \
- --with-oggvorbis \
- --with-flac \
- %{?with_samplerate:--with-external-libsamplerate} \
- %{?with_dvdread:--with-libdvdread} %{?!with_dvdread:--without-libdvdread} \
- --with-musicbrainz \
- %{?with_sndfile:--with-sndfile} %{?!with_sndfile:--without-sndfile} \
- %{?with_ffmpeg:--with-ffmpeg} %{?!with_ffmpeg:--without-ffmpeg} \
- %{?with_lame:--with-lame} %{?!with_lame:--without-lame} \
- %{?with_libmad:--with-libmad} %{?!with_libmad:--without-libmad} \
- --with-musepack \
- --without-resmgr \
- --without-hal
-
-# Strange behaviour on RHEL4 ...
-%if 0%{?rhel} == 4
-%__sed -i "libk3b/jobs/Makefile" -e "/^am_libjobs_la_final_OBJECTS/ s/ lo//g"
-%__mkdir_p "libk3bdevice/.libs"
-%__ln_s . "libk3bdevice/.libs/.libs"
-%endif
+ -DWITH_ALL_OPTIONS="ON" \
+ -DWITH_MUSICBRAINZ="OFF" \
+ -DWITH_FFMPEG_ALL_CODECS="ON" \
+ -DWITH_MUSEPACK="ON" \
+ -DWITH_LAME="%{!?with_lame:OFF}%{?with_lame:ON}" \
+ -DWITH_MAD="%{!?with_libmad:OFF}%{?with_libmad:ON}" \
+ ..
-%__make %{?_smp_mflags}
+%__make %{?_smp_mflags} || %__make
%install
export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot}
-%__install -D -m 644 -p %{SOURCE2} %{buildroot}%{tde_datadir}/config/k3brc
+%__make install DESTDIR=%{?buildroot} -C build
# remove the .la files
%__rm -f %{buildroot}%{tde_libdir}/libk3b*.la
@@ -463,5 +470,3 @@ export PATH="%{tde_bindir}:${PATH}"
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 1:1.0.5-2
-- Initial release for TDE 14.0.0