summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kbiff/kbiff-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kbiff/kbiff-14.0.0.spec')
-rw-r--r--redhat/applications/kbiff/kbiff-14.0.0.spec115
1 files changed, 72 insertions, 43 deletions
diff --git a/redhat/applications/kbiff/kbiff-14.0.0.spec b/redhat/applications/kbiff/kbiff-14.0.0.spec
index ac1633c80..1ca90aebc 100644
--- a/redhat/applications/kbiff/kbiff-14.0.0.spec
+++ b/redhat/applications/kbiff/kbiff-14.0.0.spec
@@ -1,50 +1,84 @@
-# Default version for this component
-%define tde_pkg kbiff
+#
+# spec file for package kbiff (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg kbiff
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-Name: trinity-%{tde_pkg}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
Version: 3.9
-Release: %{?!preversion:2}%{?preversion:1_%{preversion}}%{?dist}%{?_variant}
-Summary: TDE mail notification utility
-
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: TDE mail notification utility
Group: Applications/Internet
-License: GPLv2+
URL: http://www.trinitydesktop.org/
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
BuildRequires: tqt3-compat-headers >= 3.5.0
-BuildRequires: libtqt4-devel >= 2:4.2.0
-BuildRequires: trinity-arts-devel >= 2:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: gettext
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+
%description
Kbiff is a "xbiff"-like mail notification utility. It has multiple pixmaps,
session management, and GUI configuration. It can "dock" into the TDE panel.
@@ -52,15 +86,19 @@ It can display animated gifs, play system sounds, or run arbitrary shell
command when new mail arrives. It supports mbox, maildir, mh, POP3, IMAP4, and
NNTP mailboxes.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -84,7 +122,7 @@ export PATH="%{tde_bindir}:${PATH}"
--enable-closure \
--enable-rpath \
--disable-gcc-hidden-visibility
-
+
%__make %{?_smp_mflags}
@@ -94,23 +132,19 @@ export PATH="%{tde_bindir}:${PATH}"
%find_lang %{tde_pkg}
+# Fix icon location
+%__mkdir_p "%{?buildroot}%{tde_tdeappdir}"
+%__mv -f "%{?buildroot}%{tde_datadir}/applnk/Internet/kbiff.desktop" "%{?buildroot}%{tde_tdeappdir}/kbiff.desktop"
-%clean
-%__rm -rf $RPM_BUILD_ROOT
-
-
-%post
-for i in hicolor locolor ; do
- touch --no-create %{tde_datadir}/icons/$i 2>/dev/null || :
- gtk-update-icon-cache --quiet %{tde_datadir}/icons/$i 2>/dev/null || :
-done
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+echo "OnlyShowIn=TDE;" >>"%{?buildroot}%{tde_tdeappdir}/kbiff.desktop"
+%suse_update_desktop_file kbiff Applet
+%endif
-%postun
-for i in hicolor locolor ; do
- touch --no-create %{tde_datadir}/icons/$i 2>/dev/null || :
- gtk-update-icon-cache --quiet %{tde_datadir}/icons/$i 2>/dev/null || :
-done
+%clean
+%__rm -rf $RPM_BUILD_ROOT
%files -f %{tde_pkg}.lang
@@ -121,7 +155,7 @@ done
%{tde_libdir}/libtdeinit_kbiff.so
%{tde_tdelibdir}/kbiff.la
%{tde_tdelibdir}/kbiff.so
-%{tde_datadir}/applnk/Internet/kbiff.desktop
+%{tde_tdeappdir}/kbiff.desktop
%{tde_datadir}/apps/kbiff/
%{tde_datadir}/icons/hicolor/*/apps/kbiff.png
%{tde_datadir}/icons/locolor/*/apps/kbiff.png
@@ -133,8 +167,3 @@ done
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 3.9-2
-- Initial release for TDE 14.0.0
-
-* Mon Apr 08 2013 Francois Andriot <francois.andriot@free.fr> - 3.9-1
-- Initial release for TDE 3.5.13.2