summaryrefslogtreecommitdiffstats
path: root/redhat/applications/knights/knights-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/knights/knights-14.0.0.spec')
-rw-r--r--redhat/applications/knights/knights-14.0.0.spec101
1 files changed, 61 insertions, 40 deletions
diff --git a/redhat/applications/knights/knights-14.0.0.spec b/redhat/applications/knights/knights-14.0.0.spec
index ce05ede7c..a5bfff2ce 100644
--- a/redhat/applications/knights/knights-14.0.0.spec
+++ b/redhat/applications/knights/knights-14.0.0.spec
@@ -1,54 +1,82 @@
-# Default version for this component
-%define tde_pkg knights
+#
+# spec file for package knights (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg knights
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 0.6
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: A chess interface for the K Desktop Environment [Trinity]
+Group: Amusements/Games
+URL: http://www.trinitydesktop.org/
-Name: trinity-%{tde_pkg}
-Summary: A chess interface for the K Desktop Environment [Trinity]
-Version: 0.6
-Release: %{?!preversion:7}%{?preversion:6_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
-Group: Amusements/Games
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: gettext
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: libtool
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# GNUCHESS support
Requires: gnuchess
%description
@@ -66,16 +94,20 @@ Here's a quick list of Knights' key features:
* Save your unfinished matches and play them again later.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -116,15 +148,6 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%post
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-
-%postun
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-
-
%files -f %{tde_pkg}.lang
%defattr(-,root,root,-)
%{tde_bindir}/knights
@@ -136,5 +159,3 @@ gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.6-7
-- Initial release for TDE 14.0.0