summaryrefslogtreecommitdiffstats
path: root/redhat/applications/knutclient/knutclient-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/knutclient/knutclient-14.0.0.spec')
-rw-r--r--redhat/applications/knutclient/knutclient-14.0.0.spec112
1 files changed, 68 insertions, 44 deletions
diff --git a/redhat/applications/knutclient/knutclient-14.0.0.spec b/redhat/applications/knutclient/knutclient-14.0.0.spec
index e471ba9cb..a6bea6551 100644
--- a/redhat/applications/knutclient/knutclient-14.0.0.spec
+++ b/redhat/applications/knutclient/knutclient-14.0.0.spec
@@ -1,53 +1,81 @@
-# Default version for this component
-%define tde_pkg knutclient
+#
+# spec file for package knutclient (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg knutclient
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 0.9.5
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: A TDE GUI that displays UPS statistics from NUT's upsd [Trinity]
+Group: Applications/Utilities
+URL: http://www.knut.noveradsl.cz/knutclient/
-Name: trinity-%{tde_pkg}
-Summary: A TDE GUI that displays UPS statistics from NUT's upsd [Trinity]
-Version: 0.9.5
-Release: %{?!preversion:6}%{?preversion:5_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
-Group: Applications/Utilities
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.knut.noveradsl.cz/knutclient/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
%description
KNutClient monitors UPS statistics through the NUT (Network UPS Tools,
@@ -56,16 +84,23 @@ information, presented in a nice visual format, can be invaluable on
stations using an UPS.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+# Fix permissions
+chmod 644 AUTHORS README TODO COPYING ChangeLog
+
%__cp "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -100,26 +135,17 @@ export PATH="%{tde_bindir}:${PATH}"
%find_lang %{tde_pkg}
-%clean
-%__rm -rf %{buildroot}
-
+# Links duplicate files
+%fdupes "%{?buildroot}%{tde_datadir}"
-%post
-for f in hicolor locolor; do
- touch --no-create %{tde_datadir}/icons/${f} || :
- gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
-done
-%postun
-for f in hicolor locolor; do
- touch --no-create %{tde_datadir}/icons/${f} || :
- gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
-done
+%clean
+%__rm -rf %{buildroot}
%files -f %{tde_pkg}.lang
%defattr(-,root,root,-)
-%doc AUTHORS ChangeLog COPYING NEWS README TODO
+%doc AUTHORS ChangeLog COPYING README
%{tde_bindir}/knutclient
%{tde_datadir}/applnk/Utilities/knutclient.desktop
%{tde_datadir}/apps/knutclient/knutclientui.rc
@@ -130,5 +156,3 @@ done
%{tde_datadir}/icons/locolor/*/apps/*.png
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.9.5-6
-- Initial release for TDE 14.0.0