summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kopete-otr/kopete-otr-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kopete-otr/kopete-otr-14.0.0.spec')
-rw-r--r--redhat/applications/kopete-otr/kopete-otr-14.0.0.spec113
1 files changed, 65 insertions, 48 deletions
diff --git a/redhat/applications/kopete-otr/kopete-otr-14.0.0.spec b/redhat/applications/kopete-otr/kopete-otr-14.0.0.spec
index 854bd79c9..602ab32c3 100644
--- a/redhat/applications/kopete-otr/kopete-otr-14.0.0.spec
+++ b/redhat/applications/kopete-otr/kopete-otr-14.0.0.spec
@@ -1,81 +1,111 @@
-# Default version for this component
-%define tde_pkg kopete-otr
+#
+# spec file for package kopete-otr (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# Required for Mageia 2: removes the ldflag '--no-undefined'
-%define _disable_ld_no_undefined 1
-
-# Under Mageia 3, we require "libotr3" package
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg kopete-otr
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-
-Name: trinity-%{tde_pkg}
-Summary: Off-The-Record encryption for Kopete [Trinity]
-Version: 0.7
-Release: %{?!preversion:6}%{?preversion:5_%{preversion}}%{?dist}%{?_variant}
+# Required for Mageia 6: removes the ldflag '--no-undefined'
+%if 0%{?mgaversion} >= 6 || 0%{?pclinuxos} >= 2018
+%define _disable_ld_no_undefined 1
+%endif
-License: GPLv2+
-Group: Applications/Utilities
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 0.7
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Off-The-Record encryption for Kopete [Trinity]
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: trinity-tdenetwork-devel >= %{tde_version}
# Kopete is provided by tdenetwork
Requires: trinity-kopete >= %{tde_version}
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
# OTR support
BuildRequires: libotr-devel
+
%description
This plugin enables Off-The-Record encryption for the TDE instant
messenger Kopete. Using this plugin you can encrypt chatsessions to other
users with IM-Cients supporting the OTR encryption method.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -118,17 +148,6 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%post
-touch --no-create %{tde_datadir}/icons/crystalsvg || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/crystalsvg || :
-/sbin/ldconfig || :
-
-%postun
-touch --no-create %{tde_datadir}/icons/crystalsvg || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/crystalsvg || :
-/sbin/ldconfig || :
-
-
%files -f kopete_otr.lang
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING README TODO
@@ -148,5 +167,3 @@ gtk-update-icon-cache --quiet %{tde_datadir}/icons/crystalsvg || :
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.7-6
-- Initial release for TDE 14.0.0