summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kvirc/kvirc-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kvirc/kvirc-14.0.0.spec')
-rw-r--r--redhat/applications/kvirc/kvirc-14.0.0.spec137
1 files changed, 90 insertions, 47 deletions
diff --git a/redhat/applications/kvirc/kvirc-14.0.0.spec b/redhat/applications/kvirc/kvirc-14.0.0.spec
index 7b5242932..fd781dae3 100644
--- a/redhat/applications/kvirc/kvirc-14.0.0.spec
+++ b/redhat/applications/kvirc/kvirc-14.0.0.spec
@@ -1,57 +1,87 @@
-# REMOVE KDELIBS4-DEVEL before building !!!!
+%if 0%{?fedora} >= 23
+%define _hardened_ldflags %nil
+%endif
-# Default version for this component
-%define tde_pkg kvirc
+#
+# spec file for package kvirc (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg kvirc
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-Name: trinity-%{tde_pkg}
-Summary: Trinity based next generation IRC client with module support
-Version: 3.4.0
-Release: %{?!preversion:6}%{?preversion:5_%{preversion}}%{?dist}%{?_variant}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 3.4.0
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Trinity based next generation IRC client with module support
+Group: Applications/Utilities
+URL: http://kvirc.net/
-License: GPLv2+
-Group: Applications/Utilities
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://kvirc.net/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: gettext
-Requires: %{name}-data = %{version}-%{release}
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+Requires: %{name}-data = %{?epoch:%{epoch}:}%{version}-%{release}
+
%description
A highly configurable graphical IRC client with an MDI interface,
@@ -66,7 +96,7 @@ you need to install the kvirc-dev package.
%package data
Group: Applications/Utilities
Summary: Data files for KVIrc
-Requires: %{name} = %{version}-%{release}
+Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
%description data
This package contains the architecture-independent data needed by KVIrc in
@@ -82,7 +112,7 @@ with the Trinity Desktop Environment version 3.
%package devel
Group: Development/Libraries
Summary: Development files for KVIrc
-Requires: %{name} = %{version}-%{release}
+Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
%description devel
This package contains KVIrc libraries and include files you need if you
@@ -92,17 +122,28 @@ KVIrc is a graphical IRC client based on the TDE widget set which integrates
with the K Desktop Environment version 3.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+# FTBFS on RHEL 5
+%if 0%{?rhel} == 5
+%__sed -i "admin/acinclude.m4.in" \
+ -i "src/kvilib/tal/kvi_tal_application.cpp" \
+ -e "/TDEApplication/ s|\")|\", true, true, true)|";
+%endif
+
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
./autogen.sh
@@ -140,6 +181,10 @@ export PATH="%{tde_bindir}:${PATH}"
%__make symlinks -C src/kvilib/build
%__make symlinks -C src/kvirc/build
+%if 0%{?mgaversion} >= 6 || 0%{?pclinuxos} >= 2018
+%__sed -i "src/modules/"*"/Makefile" -e "s|-Wl,--no-undefined||"
+%endif
+
%__make %{?_smp_mflags}
@@ -153,20 +198,18 @@ export PATH="%{tde_bindir}:${PATH}"
%{?buildroot}%{tde_datadir}/kvirc/3.4/license/COPYING \
%{?buildroot}%{tde_datadir}/kvirc/3.4/license/EULA
+# Move desktop file to XDG location
+%__mkdir_p "%{?buildroot}%{tde_tdeappdir}"
+%__mv -f "%{?buildroot}%{tde_datadir}/applnk/"*"/%{tde_pkg}.desktop" "%{?buildroot}%{tde_tdeappdir}"
-%clean
-%__rm -rf %{buildroot}
-
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file kvirc Network IRCClient
+%endif
-%post
-/sbin/ldconfig
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-%postun
-/sbin/ldconfig
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
+%clean
+%__rm -rf %{buildroot}
%files
@@ -180,8 +223,10 @@ gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
%defattr(-,root,root,-)
%{tde_bindir}/kvi_run_netscape
%{tde_bindir}/kvi_search_help
+%exclude %{tde_libdir}/kvirc/*/modules/*.la
+%exclude %{tde_libdir}/kvirc/*/modules/*.so
%{tde_libdir}/kvirc/
-%{tde_datadir}/applnk/Internet/kvirc.desktop
+%{tde_tdeappdir}/kvirc.desktop
%{tde_datadir}/icons/hicolor/*/*/*.png
%{tde_datadir}/icons/hicolor/*/*/*.svgz
%{tde_datadir}/icons/hicolor/*/*/*.xpm
@@ -200,5 +245,3 @@ gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 3.4.0-6
-- Initial release for TDE 14.0.0