summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tellico/tellico.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/tellico/tellico.spec')
-rw-r--r--redhat/applications/tellico/tellico.spec14
1 files changed, 13 insertions, 1 deletions
diff --git a/redhat/applications/tellico/tellico.spec b/redhat/applications/tellico/tellico.spec
index fa04c4ba8..eb1b910a1 100644
--- a/redhat/applications/tellico/tellico.spec
+++ b/redhat/applications/tellico/tellico.spec
@@ -153,6 +153,18 @@ BuildRequires: libacl-devel
# ATTR support
BuildRequires: libattr-devel
+# PYTHON support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
+%global python python2
+%global __python %__python2
+%global python_sitearch %{python2_sitearch}
+%else
+%global python python
+%endif
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+BuildRequires: %{python}
+BuildRequires: %{python}-devel
+
Requires: %{name}-data = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: %{name}-scripts = %{?epoch:%{epoch}:}%{version}-%{release}
@@ -272,7 +284,7 @@ if [ -r /usr/include/libv4l1-videodev.h ]; then
%__sed -i "src/barcode/barcode_v4l.h" -e "s|linux/videodev.h|libv4l1.h|"
fi
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
%__sed -i "src/fetch/scripts/dark_horse_comics.py" \
"src/fetch/scripts/ministerio_de_cultura.py" \
"src/fetch/scripts/fr.allocine.py" \