summaryrefslogtreecommitdiffstats
path: root/redhat/applications/wlassistant/wlassistant.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/wlassistant/wlassistant.spec')
-rw-r--r--redhat/applications/wlassistant/wlassistant.spec13
1 files changed, 8 insertions, 5 deletions
diff --git a/redhat/applications/wlassistant/wlassistant.spec b/redhat/applications/wlassistant/wlassistant.spec
index ac0d47820..2859a9094 100644
--- a/redhat/applications/wlassistant/wlassistant.spec
+++ b/redhat/applications/wlassistant/wlassistant.spec
@@ -100,14 +100,17 @@ BuildRequires: libidn-devel
BuildRequires: gamin-devel
%endif
-# PYTHON
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31
-%define python python2
-%define __python %__python2
+# PYTHON support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%global python python2
+%global __python %__python2
+%global python_sitearch %{python2_sitearch}
%else
-%define python python
+%global python python
%endif
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
BuildRequires: %{python}
+BuildRequires: %{python}-devel
# OPENSSL support
BuildRequires: openssl-devel