summaryrefslogtreecommitdiffstats
path: root/redhat/applications/yakuake/yakuake-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/yakuake/yakuake-14.0.0.spec')
-rw-r--r--redhat/applications/yakuake/yakuake-14.0.0.spec98
1 files changed, 59 insertions, 39 deletions
diff --git a/redhat/applications/yakuake/yakuake-14.0.0.spec b/redhat/applications/yakuake/yakuake-14.0.0.spec
index 50b4d4848..147f62366 100644
--- a/redhat/applications/yakuake/yakuake-14.0.0.spec
+++ b/redhat/applications/yakuake/yakuake-14.0.0.spec
@@ -1,66 +1,97 @@
-# Default version for this component
-%define tde_pkg yakuake
+#
+# spec file for package yakuake (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg yakuake
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_tdedocdir}
-
-Name: trinity-%{tde_pkg}
-Summary: Yakuake is a Quake-style terminal emulator based on TDE Konsole technology.
-Version: 2.8.1
-Release: %{?!preversion:7}%{?preversion:6_%{preversion}}%{?dist}%{?_variant}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 2.8.1
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Yakuake is a Quake-style terminal emulator based on TDE Konsole technology
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
-License: GPLv2+
-Group: Applications/Utilities
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
%description
Yakuake is a Quake-style terminal emulator based on TDE Konsole technology.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -98,15 +129,6 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%post
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-
-%postun
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-
-
%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING
@@ -120,5 +142,3 @@ gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2.8.1-7
-- Initial release for TDE 14.0.0