summaryrefslogtreecommitdiffstats
path: root/redhat/core/tdetoys/tdetoys.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/core/tdetoys/tdetoys.spec')
-rw-r--r--redhat/core/tdetoys/tdetoys.spec12
1 files changed, 10 insertions, 2 deletions
diff --git a/redhat/core/tdetoys/tdetoys.spec b/redhat/core/tdetoys/tdetoys.spec
index eb823346d..48cf7218a 100644
--- a/redhat/core/tdetoys/tdetoys.spec
+++ b/redhat/core/tdetoys/tdetoys.spec
@@ -21,7 +21,7 @@
# TDE variables
%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
+%define tde_version 14.1.2
%endif
%define tde_pkg tdetoys
%define tde_prefix /opt/trinity
@@ -93,13 +93,21 @@ BuildRequires: gamin-devel
%endif
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# PCRE support
BuildRequires: pcre-devel
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
Obsoletes: trinity-kdetoys < %{?epoch:%{epoch}:}%{version}-%{release}
@@ -399,7 +407,7 @@ This package is part of Trinity, and a component of the TDE toys module.
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi