summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/libcaldav/libcaldav.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/dependencies/libcaldav/libcaldav.spec')
-rw-r--r--redhat/dependencies/libcaldav/libcaldav.spec13
1 files changed, 11 insertions, 2 deletions
diff --git a/redhat/dependencies/libcaldav/libcaldav.spec b/redhat/dependencies/libcaldav/libcaldav.spec
index 29569afb4..0fe560871 100644
--- a/redhat/dependencies/libcaldav/libcaldav.spec
+++ b/redhat/dependencies/libcaldav/libcaldav.spec
@@ -18,7 +18,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
+%define tde_version 14.1.2
%endif
%define tde_pkg libcaldav
%define tde_prefix /opt/trinity
@@ -60,16 +60,24 @@ BuildRequires: libtool
BuildRequires: fdupes
# GTK2 support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}gtk+2.0-devel
+%else
%if 0%{?rhel} == 4
BuildRequires: evolution28-gtk2-devel
%else
BuildRequires: glib2-devel
BuildRequires: gtk2-devel
%endif
+%endif
# CURL support
%if 0%{?fedora} || 0%{?rhel} >= 6 || 0%{?suse_version} || 0%{?mgaversion} || 0%{?mdkversion}
+%if 0%{?mgaversion} || 0%{?mdkversion}
+%define libcurl_devel %{_lib}curl-devel >= 7.15.5
+%else
%define libcurl_devel libcurl-devel >= 7.15.5
+%endif
%else
%define libcurl_devel curl-devel >= 7.15.5
%endif
@@ -156,7 +164,7 @@ This package includes the development files.
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi
@@ -171,6 +179,7 @@ fi
-DWITH_GCC_VISIBILITY=OFF \
\
-DCMAKE_INSTALL_PREFIX="%{_prefix}" \
+ -DLIB_INSTALL_DIR="%{_libdir}" \
-DSHARE_INSTALL_PREFIX="%{_datadir}" \
\
-DWITH_ALL_OPTIONS=ON \