summaryrefslogtreecommitdiffstats
path: root/redhat/libraries/python-trinity/python-trinity.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/libraries/python-trinity/python-trinity.spec')
-rw-r--r--redhat/libraries/python-trinity/python-trinity.spec11
1 files changed, 6 insertions, 5 deletions
diff --git a/redhat/libraries/python-trinity/python-trinity.spec b/redhat/libraries/python-trinity/python-trinity.spec
index 30ed147c1..56edb835f 100644
--- a/redhat/libraries/python-trinity/python-trinity.spec
+++ b/redhat/libraries/python-trinity/python-trinity.spec
@@ -63,13 +63,14 @@ BuildRequires: autoconf automake libtool m4
BuildRequires: gcc-c++
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31
-%define python python2
-%define __python %__python2
-%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%global python python2
+%global __python %__python2
+%global python_sitearch %{python2_sitearch}
%else
-%define python python
+%global python python
%endif
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
BuildRequires: %{python}
BuildRequires: %{python}-devel