summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdebase/tdebase.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdebase/tdebase.spec')
-rw-r--r--redhat/main/tdebase/tdebase.spec31
1 files changed, 29 insertions, 2 deletions
diff --git a/redhat/main/tdebase/tdebase.spec b/redhat/main/tdebase/tdebase.spec
index cf33058c7..0683fd7be 100644
--- a/redhat/main/tdebase/tdebase.spec
+++ b/redhat/main/tdebase/tdebase.spec
@@ -261,6 +261,14 @@ Requires: fedora-logos
%define tde_starticon /usr/share/icons/hicolor/96x96/apps/fedora-logo-icon.png
%endif
+# Fedora 33 Theme
+%if 0%{?fedora} == 33
+Requires: f33-backgrounds-base
+%define tde_bg /usr/share/backgrounds/f33/default/standard/f33.png
+Requires: fedora-logos
+%define tde_starticon /usr/share/icons/hicolor/96x96/apps/fedora-logo-icon.png
+%endif
+
# RHEL 4 Theme
%if 0%{?rhel} == 4
Requires: desktop-backgrounds-basic
@@ -430,6 +438,14 @@ Requires: hicolor-icon-theme-branding
%define tde_starticon /usr/share/icons/hicolor/scalable/apps/distributor.svg
%endif
+# OpenSuse 15.2 Theme
+%if "%{?suse_version}" == "1520"
+Requires: wallpaper-branding
+%define tde_bg /usr/share/wallpapers/openSUSEdefault/contents/images/1600x1200.jpg
+Requires: hicolor-icon-theme-branding
+%define tde_starticon /usr/share/icons/hicolor/scalable/apps/distributor.svg
+%endif
+
# OpenSuse TW Theme
%if "%{?suse_version}" == "1550"
Requires: wallpaper-branding
@@ -2386,7 +2402,9 @@ fi
# openSUSE 15.0 alternatives
%if 0%{?suse_version} >= 1500
-update-alternatives --remove default-displaymanager /usr/lib/X11/displaymanagers/tdm || :
+if [ "$1" = "0" ]; then
+ update-alternatives --remove default-displaymanager /usr/lib/X11/displaymanagers/tdm || :
+fi
%endif
##########
@@ -3341,6 +3359,15 @@ Windows and Samba shares.
%if 0%{?suse_version}
%__sed -i "%{tdm}/kfrontend/gen%{tdm}conf.c" -e "s|/etc/X11/Xsession|/etc/X11/xdm/Xsession|"
%endif
+%if 0%{?suse_version} >= 1550
+# /etc/X11 moved to /usr/etc/X11 on opensuse TW
+%__sed -i "%{tdm}/kfrontend/gen%{tdm}conf.c" \
+ -i "%{tdm}/README" \
+ -i "doc/adminguide/index.docbook" \
+ -i "doc/faq/notrelated.docbook" \
+ -e "s|/etc/X11/xdm|/usr/etc/X11/xdm|g" \
+ -e "s|/etc/X11/sessions|/usr/etc/X11/sessions|g"
+%endif
# Reboot command location may vary on some distributions
if [ -x "/usr/bin/reboot" ]; then
@@ -3613,7 +3640,7 @@ EOF
# Move faces icon to XDG directory '/usr/share/faces'
if [ ! -d "%{?buildroot}%{_datadir}/faces" ]; then
%__mkdir_p "%{?buildroot}%{_datadir}/faces"
- %__mv -f "%{?buildroot}%{tdm_datadir}/pics/users/"* "%{?buildroot}%{_datadir}/faces"
+ %__mv -f "%{?buildroot}%{tdm_datadir}/pics/users/"* "%{?buildroot}%{_datadir}/faces" 2>/dev/null
rmdir "%{?buildroot}%{tdm_datadir}/pics/users"
fi
%__ln_s "%{_datadir}/faces" "%{?buildroot}%{tdm_datadir}/pics/users"