summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdebindings/tdebindings.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdebindings/tdebindings.spec')
-rw-r--r--redhat/main/tdebindings/tdebindings.spec14
1 files changed, 7 insertions, 7 deletions
diff --git a/redhat/main/tdebindings/tdebindings.spec b/redhat/main/tdebindings/tdebindings.spec
index 141c1d8aa..752b77632 100644
--- a/redhat/main/tdebindings/tdebindings.spec
+++ b/redhat/main/tdebindings/tdebindings.spec
@@ -168,17 +168,17 @@ BuildRequires: Mesa-libGL-devel
BuildRequires: Mesa-libGLU-devel
%endif
-
-## Python
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31
-%define python python2
-%define __python %__python2
+# PYTHON support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%global python python2
+%global __python %__python2
+%global python_sitearch %{python2_sitearch}
%else
-%define python python
+%global python python
%endif
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
BuildRequires: %{python}
BuildRequires: %{python}-devel
-%define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
## ruby
BuildRequires: ruby-devel >= 1.8