summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdepim/tdepim-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdepim/tdepim-14.0.0.spec')
-rw-r--r--redhat/main/tdepim/tdepim-14.0.0.spec564
1 files changed, 58 insertions, 506 deletions
diff --git a/redhat/main/tdepim/tdepim-14.0.0.spec b/redhat/main/tdepim/tdepim-14.0.0.spec
index 6f8a7642c..bdedc6699 100644
--- a/redhat/main/tdepim/tdepim-14.0.0.spec
+++ b/redhat/main/tdepim/tdepim-14.0.0.spec
@@ -1,5 +1,5 @@
#
-# spec file for package tdepim (version R14.0.0)
+# spec file for package tdepim (version R14)
#
# Copyright (c) 2014 Trinity Desktop Environment
#
@@ -12,7 +12,7 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
-# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
#
# BUILD WARNING:
@@ -21,10 +21,13 @@
# TDE variables
%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
+%endif
%define tde_pkg tdepim
%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
+%define tde_confdir %{_sysconfdir}/trinity
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
@@ -34,11 +37,6 @@
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
# KDEPIM specific features
%if 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion} || 0%{?suse_version}
@@ -53,7 +51,7 @@ BuildRequires: gnokii-devel
Name: trinity-%{tde_pkg}
Summary: Personal Information Management apps from the official Trinity release
Version: %{tde_version}
-Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
Group: Applications/Productivity
URL: http://www.trinitydesktop.org/
@@ -70,6 +68,7 @@ Prefix: %{tde_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
+Source1: %{name}-rpmlintrc
BuildRequires: trinity-arts-devel >= %{tde_epoch}:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
@@ -91,6 +90,9 @@ BuildRequires: boost-devel
BuildRequires: pcre-devel
BuildRequires: libidn-devel
+# OPENSSL support
+BuildRequires: openssl-devel
+
# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files
@@ -108,15 +110,13 @@ BuildRequires: brp-check-trinity
BuildRequires: gamin-devel
%endif
-# CURL support
+# FLEX support
%if 0%{?fedora} >= 15
BuildRequires: flex-static
%endif
-%if 0%{?rhel} > 0 && 0%{?rhel} <= 5
-BuildRequires: trinity-libcurl-devel
-%else
+
+# CURL support
BuildRequires: curl-devel
-%endif
# GLIB2 support
BuildRequires: glib2-devel
@@ -141,28 +141,47 @@ BuildRequires: libXcomposite-devel
%endif
# XSCREENSAVER support
-# Disabled on RHEL4
-%if 0%{?fedora} >= 15 || 0%{?mgaversion} || 0%{?mdkversion} || 0%{?rhel} >= 5 || 0%{?suse_version}
+# RHEL 4: disabled
+# RHEL 6: available in EPEL
+# RHEL 7: available in NUX
+%if 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion} || 0%{?rhel} >= 5 || 0%{?suse_version}
%define with_xscreensaver 1
-%if 0%{?rhel} == 5
-BuildRequires: xorg-x11-proto-devel
-BuildRequires: gnome-screensaver
+
+%if 0%{?fedora} || 0%{?rhel} >= 5
+BuildRequires: libXScrnSaver-devel
+BuildRequires: xscreensaver
+BuildRequires: xscreensaver-base
+BuildRequires: xscreensaver-extras
+%if 0%{?fedora}
+BuildRequires: xscreensaver-extras-base
%endif
+BuildRequires: xscreensaver-gl-base
+BuildRequires: xscreensaver-gl-extras
+%endif
+
+%if 0%{?suse_version}
+BuildRequires: libXScrnSaver-devel
+BuildRequires: xscreensaver
+BuildRequires: xscreensaver-data
+BuildRequires: xscreensaver-data-extra
+%endif
+
%if 0%{?mgaversion} || 0%{?mdkversion}
%if 0%{?mgaversion} >= 4
BuildRequires: %{_lib}xscrnsaver-devel
%else
BuildRequires: %{_lib}xscrnsaver%{?mgaversion:1}-devel
%endif
-%endif
-%if 0%{?fedora} || 0%{?rhel} >= 6 || 0%{?suse_version} >= 1220
-BuildRequires: libXScrnSaver-devel
-%endif
-%if 0%{?suse_version} == 1140
BuildRequires: xscreensaver
+BuildRequires: xscreensaver-base
+BuildRequires: xscreensaver-extrusion
+BuildRequires: xscreensaver-gl
%endif
%endif
+# ACL support
+BuildRequires: libacl-devel
+
Requires: trinity-libtdepim = %{version}-%{release}
Requires: %{name}-kfile-plugins = %{version}-%{release}
@@ -207,6 +226,7 @@ This metapackage includes a collection of Personal Information Management
(PIM) applications provided with the official release of Trinity.
%files
+%defattr(-,root,root,-)
##########
@@ -289,22 +309,6 @@ thousands of internet feeds in a quick, efficient, and familiar way.
%{tde_tdedocdir}/HTML/en/akregator/
%{tde_tdedocdir}/HTML/en/tdeioslave/feed/
-%post -n trinity-akregator
-/sbin/ldconfig || :
-for f in crystalsvg hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-akregator
-/sbin/ldconfig || :
-for f in crystalsvg hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-akregator-devel
@@ -321,18 +325,12 @@ Requires: trinity-akregator = %{version}-%{release}
%{tde_libdir}/libakregatorprivate.la
%{tde_libdir}/libakregatorprivate.so
-%post -n trinity-akregator-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-akregator-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-kaddressbook
Summary: TDE addressbook application
Group: Applications/Communications
-Requires: trinity-kdebase-pim-ioslaves
+Requires: trinity-tdebase-tdeio-pim-plugins
Requires: %{name}-tderesources = %{version}-%{release}
%description -n trinity-kaddressbook
@@ -381,22 +379,6 @@ LDAP servers, and SQL databases.
%{tde_tdeincludedir}/kaddressbook/
%{tde_tdeincludedir}/tdeabc/
-%post -n trinity-kaddressbook
-/sbin/ldconfig || :
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-kaddressbook
-/sbin/ldconfig || :
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-kaddressbook-devel
@@ -414,12 +396,6 @@ Requires: trinity-kaddressbook = %{version}-%{release}
%{tde_libdir}/libkaddressbook.la
%{tde_libdir}/libkaddressbook.so
-%post -n trinity-kaddressbook-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-kaddressbook-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-kalarm
@@ -456,20 +432,6 @@ TDE-based, but will also run on other desktops.
%{tde_datadir}/icons/hicolor/*/apps/kalarm.png
%{tde_tdedocdir}/HTML/en/kalarm/
-%post -n trinity-kalarm
-for f in crystalsvg hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-kalarm
-for f in crystalsvg hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-kandy
@@ -496,20 +458,6 @@ Kandy is aimed at mobile phones with integrated (GSM) modems.
%{tde_datadir}/config.kcfg/kandy.kcfg
%{tde_tdedocdir}/HTML/en/kandy/
-%post -n trinity-kandy
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-kandy
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-karm
@@ -535,22 +483,6 @@ time they spend on various tasks.
%{tde_datadir}/services/kontact/karmplugin.desktop
%{tde_tdedocdir}/HTML/en/karm/
-%post -n trinity-karm
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-karm
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-karm-devel
@@ -565,12 +497,6 @@ Group: Development/Libraries/Other
%{tde_libdir}/libkarm.so
%{tde_libdir}/libkarm.la
-%post -n trinity-karm-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-karm-devel
-/sbin/ldconfig || :
-
##########
%package kfile-plugins
@@ -747,12 +673,6 @@ tracking feature plans.
%{tde_tdelibdir}/tdeabc_xmlrpc.la
%{tde_tdelibdir}/tdeabc_xmlrpc.so
-%post tderesources
-/sbin/ldconfig || :
-
-%postun tderesources
-/sbin/ldconfig || :
-
##########
%package tderesources-devel
@@ -821,12 +741,6 @@ Provides: trinity-tdepim-kresources-devel = %{version}-%{release}
%{tde_libdir}/libknotesscalix.so
%{tde_tdeincludedir}/kpimprefs.h
-%post tderesources-devel
-/sbin/ldconfig || :
-
-%postun tderesources-devel
-/sbin/ldconfig || :
-
##########
%package wizards
@@ -868,12 +782,6 @@ Kolab, and SUSE Linux Openexchange servers.
%{tde_datadir}/config.kcfg/scalix.kcfg
%{tde_datadir}/config.kcfg/slox.kcfg
-%post wizards
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun wizards
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%if 0%{?with_kitchensync}
@@ -898,14 +806,6 @@ development (?). Kitchensync uses opensync.
%{tde_libdir}/libqopensync.so.*
%{tde_tdeappdir}/kitchensync.desktop
%{tde_datadir}/icons/hicolor/*/apps/kitchensync.png
-
-%post -n trinity-kitchensync
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-kitchensync
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
%endif
##########
@@ -949,27 +849,13 @@ keybox and for retrieving certificates from LDAP servers.
%{tde_tdedocdir}/HTML/en/kwatchgnupg/
%{tde_datadir}/icons/hicolor/*/apps/kleopatra.png
-%post -n trinity-kleopatra
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-
-%postun -n trinity-kleopatra
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-
##########
%package -n trinity-kmail
Summary: Trinity Email client
Group: Applications/Communications
Requires: %{name}-tdeio-plugins = %{version}-%{release}
-Requires: trinity-tdebase-tdeio-pim-plugins >= %{version}
+Requires: trinity-tdebase-tdeio-pim-plugins >= %{tde_version}
# GPG support
%if 0%{?suse_version}
@@ -990,7 +876,7 @@ Requires: pinentry
Requires: procmail
Requires: trinity-kaddressbook = %{version}-%{release}
Requires: trinity-kleopatra = %{version}-%{release}
-Requires: trinity-tdebase-tdeio-pim-plugins >= %{version}-%{release}
+Requires: trinity-tdebase-tdeio-pim-plugins >= %{tde_version}
Provides: imap-client, mail-reader
@@ -1004,8 +890,8 @@ mbox files, and/or trinity-tdebase-tdeio-plugins if you want to use POP3.
%files -n trinity-kmail
%defattr(-,root,root,-)
-%{tde_datadir}/config/kmail.antispamrc
-%{tde_datadir}/config/kmail.antivirusrc
+%{tde_confdir}/kmail.antispamrc
+%{tde_confdir}/kmail.antivirusrc
%{tde_bindir}/kmail
%{tde_bindir}/kmail_*.sh
%{tde_tdelibdir}/kcm_kmail.la
@@ -1061,22 +947,6 @@ mbox files, and/or trinity-tdebase-tdeio-plugins if you want to use POP3.
%{tde_libdir}/libkmailprivate.la
%{tde_tdedocdir}/HTML/en/kmail/
-%post -n trinity-kmail
-for f in crystalsvg hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-kmail
-for f in crystalsvg hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-kmail-devel
@@ -1092,12 +962,6 @@ Group: Development/Libraries/Other
%{tde_tdeincludedir}/kmail/
%{tde_tdeincludedir}/kmail*.h
-%post -n trinity-kmail-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-kmail-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-kmailcvt
@@ -1116,18 +980,6 @@ include Outlook Express, Evolution, and plain mbox.
%{tde_datadir}/apps/kmailcvt
%{tde_datadir}/icons/crystalsvg/*/apps/kmailcvt.png
-%post -n trinity-kmailcvt
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-
-%postun -n trinity-kmailcvt
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-
##########
%package -n trinity-knode
@@ -1157,22 +1009,6 @@ signatures.
%{tde_datadir}/services/kontact/knodeplugin.desktop
%{tde_tdedocdir}/HTML/en/knode/
-%post -n trinity-knode
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-knode
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-knode-devel
@@ -1188,12 +1024,6 @@ Requires: trinity-knode = %{version}-%{release}
%{tde_libdir}/libknodecommon.la
%{tde_libdir}/libknodecommon.so
-%post -n trinity-knode-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-knode-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-knotes
@@ -1223,22 +1053,6 @@ program. The program supports printing and mailing your notes.
%{tde_datadir}/services/kontact/knotesplugin.desktop
%{tde_tdedocdir}/HTML/en/knotes/
-%post -n trinity-knotes
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-knotes
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-knotes-devel
@@ -1257,12 +1071,6 @@ Requires: %{name}-tderesources-devel = %{version}-%{release}
%{tde_tdeincludedir}/KNotesAppIface.h
%{tde_tdeincludedir}/KNotesIface.h
-%post -n trinity-knotes-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-knotes-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-kode
@@ -1280,12 +1088,6 @@ described by RelaxNG schemes.
%{tde_bindir}/kxml_compiler
%{tde_libdir}/libkode.so.*
-%post -n trinity-kode
-/sbin/ldconfig || :
-
-%postun -n trinity-kode
-/sbin/ldconfig || :
-
##########
%package -n trinity-kode-devel
@@ -1301,12 +1103,6 @@ Requires: trinity-kode = %{version}-%{release}
%{tde_libdir}/libkode.la
%{tde_libdir}/libkode.so
-%post -n trinity-kode-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-kode-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-konsolekalendar
@@ -1325,20 +1121,6 @@ frontend to manage your calendars.
%{tde_datadir}/icons/crystalsvg/*/apps/konsolekalendar.png
%{tde_tdedocdir}/HTML/en/konsolekalendar/
-%post -n trinity-konsolekalendar
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-konsolekalendar
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-kontact
@@ -1397,22 +1179,6 @@ scheduling, address book and other PIM functionality.
%{tde_datadir}/servicetypes/kontactplugin.desktop
%{tde_tdedocdir}/HTML/en/kontact/
-%post -n trinity-kontact
-for f in crystalsvg hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-kontact
-for f in crystalsvg hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-kontact-devel
@@ -1431,12 +1197,6 @@ Requires: trinity-kontact = %{version}-%{release}
%{tde_libdir}/libkpinterfaces.so
%{tde_tdeincludedir}/kontact/
-%post -n trinity-kontact-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-kontact-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-korganizer
@@ -1482,6 +1242,7 @@ installed.
%{tde_datadir}/autostart/korgac.desktop
%{tde_datadir}/config.kcfg/korganizer.kcfg
%{tde_datadir}/icons/hicolor/*/apps/korganizer.png
+%dir %{tde_datadir}/services/kontact
%{tde_datadir}/services/kontact/korganizerplugin.desktop
%{tde_datadir}/services/kontact/journalplugin.desktop
%{tde_datadir}/services/kontact/todoplugin.desktop
@@ -1496,22 +1257,6 @@ installed.
%{tde_tdedocdir}/HTML/en/korganizer/
%{tde_tdedocdir}/HTML/en/tdeioslave/webcal/
-%post -n trinity-korganizer
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-korganizer
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-korganizer-devel
@@ -1537,12 +1282,6 @@ Requires: trinity-korganizer = %{version}-%{release}
%{tde_libdir}/libkorganizer_eventviewer.la
%{tde_libdir}/libkorganizer_eventviewer.so
-%post -n trinity-korganizer-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-korganizer-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-korn
@@ -1570,22 +1309,6 @@ Korn run a program once you click on the docked icon in Kicker.
%{tde_datadir}/icons/hicolor/*/apps/korn.png
%{tde_tdedocdir}/HTML/en/korn/
-%post -n trinity-korn
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-korn
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-ktnef
@@ -1607,20 +1330,6 @@ mail servers and embed the mail properties as well as the actual attachments.
%{tde_datadir}/mimelnk/application/ms-tnef.desktop
%{tde_tdedocdir}/HTML/en/ktnef/
-%post -n trinity-ktnef
-for f in hicolor locolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-ktnef
-for f in hicolor locolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%package -n trinity-libindex
@@ -1637,12 +1346,6 @@ This is the runtime package for programs that use the libindex library.
%defattr(-,root,root,-)
%{tde_libdir}/libindex.so.*
-%post -n trinity-libindex
-/sbin/ldconfig || :
-
-%postun -n trinity-libindex
-/sbin/ldconfig || :
-
##########
%package -n trinity-libindex-devel
@@ -1664,12 +1367,6 @@ library.
%{tde_libdir}/libindex.la
%{tde_libdir}/libindex.so
-%post -n trinity-libindex-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libindex-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkcal
@@ -1697,7 +1394,8 @@ This is the runtime package for programs that use the libkcal-trinity library.
%{tde_libdir}/libkcal.so.*
%{tde_libdir}/libkcal_resourceremote.so.*
%{tde_libdir}/libkholidays.so.*
-%{tde_datadir}/apps/libkholidays
+%{tde_datadir}/apps/libkholidays/
+%dir %{tde_datadir}/services/tderesources/kcal
%{tde_datadir}/services/tderesources/kcal/imap.desktop
%{tde_datadir}/services/tderesources/kcal/tdeabc.desktop
%{tde_datadir}/services/tderesources/kcal/local.desktop
@@ -1705,12 +1403,6 @@ This is the runtime package for programs that use the libkcal-trinity library.
%{tde_datadir}/services/tderesources/kcal/remote.desktop
%{tde_datadir}/services/tderesources/kcal_manager.desktop
-%post -n trinity-libkcal
-/sbin/ldconfig || :
-
-%postun -n trinity-libkcal
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkcal-devel
@@ -1738,12 +1430,6 @@ library.
%{tde_libdir}/libkholidays.la
%{tde_libdir}/libkholidays.so
-%post -n trinity-libkcal-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libkcal-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libtdepim
@@ -1772,20 +1458,6 @@ This is the runtime package for programs that use the trinity-libtdepim library.
%{tde_datadir}/icons/crystalsvg/22x22/actions/button_fewer.png
%{tde_datadir}/icons/crystalsvg/22x22/actions/button_more.png
-%post -n trinity-libtdepim
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-
-%postun -n trinity-libtdepim
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-
##########
%package -n trinity-libtdepim-devel
@@ -1807,12 +1479,6 @@ library.
%{tde_libdir}/libtdepim.la
%{tde_libdir}/libtdepim.so
-%post -n trinity-libtdepim-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libtdepim-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkgantt
@@ -1827,12 +1493,6 @@ This is the runtime package for programs that use the libkgantt-trinity library.
%{tde_libdir}/libkgantt.so.*
%{tde_datadir}/apps/kgantt
-%post -n trinity-libkgantt
-/sbin/ldconfig || :
-
-%postun -n trinity-libkgantt
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkgantt-devel
@@ -1851,12 +1511,6 @@ library.
%{tde_libdir}/libkgantt.la
%{tde_libdir}/libkgantt.so
-%post -n trinity-libkgantt-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libkgantt-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkleopatra
@@ -1872,7 +1526,7 @@ This is the runtime package for programs that use the libkleopatra-trinity libra
%files -n trinity-libkleopatra
%defattr(-,root,root,-)
-%{tde_datadir}/config/libkleopatrarc
+%{tde_confdir}/libkleopatrarc
%{tde_libdir}/libgpgme++.so.*
%{tde_libdir}/libkleopatra.so.*
%{tde_libdir}/libkpgp.so.*
@@ -1883,20 +1537,6 @@ This is the runtime package for programs that use the libkleopatra-trinity libra
%{tde_datadir}/icons/crystalsvg/*/apps/gpg.png
%{tde_datadir}/icons/crystalsvg/*/apps/gpgsm.png
-%post -n trinity-libkleopatra
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-
-%postun -n trinity-libkleopatra
-for f in crystalsvg ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkleopatra-devel
@@ -1926,12 +1566,6 @@ libkleopatra-trinity library.
%{tde_libdir}/libqgpgme.la
%{tde_libdir}/libqgpgme.so
-%post -n trinity-libkleopatra-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libkleopatra-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkmime
@@ -1947,12 +1581,6 @@ an object tree.
%defattr(-,root,root,-)
%{tde_libdir}/libkmime.so.*
-%post -n trinity-libkmime
-/sbin/ldconfig || :
-
-%postun -n trinity-libkmime
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkmime-devel
@@ -1968,12 +1596,6 @@ Requires: trinity-libkmime = %{version}-%{release}
%{tde_libdir}/libkmime.la
%{tde_libdir}/libkmime.so
-%post -n trinity-libkmime-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libkmime-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkpimexchange
@@ -1990,12 +1612,6 @@ library.
%{tde_tdelibdir}/resourcecalendarexchange.so
%{tde_libdir}/libkpimexchange.so.*
-%post -n trinity-libkpimexchange
-/sbin/ldconfig || :
-
-%postun -n trinity-libkpimexchange
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkpimexchange-devel
@@ -2017,12 +1633,6 @@ libkpimexchange-trinity library.
%{tde_libdir}/libkpimexchange.la
%{tde_libdir}/libkpimexchange.so
-%post -n trinity-libkpimexchange-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libkpimexchange-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkpimidentities
@@ -2040,12 +1650,6 @@ library.
%defattr(-,root,root,-)
%{tde_libdir}/libkpimidentities.so.*
-%post -n trinity-libkpimidentities
-/sbin/ldconfig || :
-
-%postun -n trinity-libkpimidentities
-/sbin/ldconfig || :
-
##########
%package -n trinity-libkpimidentities-devel
@@ -2061,12 +1665,6 @@ Requires: trinity-libkpimidentities = %{version}-%{release}
%{tde_libdir}/libkpimidentities.la
%{tde_libdir}/libkpimidentities.so
-%post -n trinity-libkpimidentities-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libkpimidentities-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libksieve
@@ -2081,12 +1679,6 @@ This is the runtime package for programs that use the libksieve-trinity library.
%{tde_libdir}/libksieve.so.*
%{tde_tdedocdir}/HTML/en/tdeioslave/sieve/
-%post -n trinity-libksieve
-/sbin/ldconfig || :
-
-%postun -n trinity-libksieve
-/sbin/ldconfig || :
-
##########
%package -n trinity-libksieve-devel
@@ -2105,12 +1697,6 @@ library.
%{tde_libdir}/libksieve.la
%{tde_libdir}/libksieve.so
-%post -n trinity-libksieve-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libksieve-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libktnef
@@ -2129,12 +1715,6 @@ This is the runtime library for packages using the ktnef-trinity library.
%defattr(-,root,root,-)
%{tde_libdir}/libktnef.so.*
-%post -n trinity-libktnef
-/sbin/ldconfig || :
-
-%postun -n trinity-libktnef
-/sbin/ldconfig || :
-
##########
%package -n trinity-libktnef-devel
@@ -2158,12 +1738,6 @@ ktnef-trinity library.
%{tde_libdir}/libktnef.la
%{tde_libdir}/libktnef.so
-%post -n trinity-libktnef-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libktnef-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-libmimelib
@@ -2179,12 +1753,6 @@ This is the runtime package for programs that use the libmimelib-trinity library
%defattr(-,root,root,-)
%{tde_libdir}/libmimelib.so.*
-%post -n trinity-libmimelib
-/sbin/ldconfig || :
-
-%postun -n trinity-libmimelib
-/sbin/ldconfig || :
-
##########
%package -n trinity-libmimelib-devel
@@ -2204,12 +1772,6 @@ libmimelib library.
%{tde_libdir}/libmimelib.la
%{tde_libdir}/libmimelib.so
-%post -n trinity-libmimelib-devel
-/sbin/ldconfig || :
-
-%postun -n trinity-libmimelib-devel
-/sbin/ldconfig || :
-
##########
%package -n trinity-kmobile
@@ -2244,20 +1806,6 @@ dialing calls, phonebook, and phone status monitoring.
%{tde_libdir}/libkmobiledevice.so
%{tde_tdedocdir}/HTML/en/kmobile/
-%post -n trinity-kmobile
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
-%postun -n trinity-kmobile
-for f in hicolor ; do
- touch --no-create %{tde_datadir}/icons/${f} 2> /dev/null ||:
- gtk-update-icon-cache -q %{tde_datadir}/icons/${f} 2> /dev/null ||:
-done
-update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
-
##########
%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
@@ -2269,6 +1817,11 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
%prep
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
+# Fix 'ical2vcal' contains '/bin/perl' instead of '/usr/bin/perl'
+if [ -x /usr/bin/perl ]; then
+ %__sed -i "korganizer/ical2vcal.in" -e "s|@PERL@|/usr/bin/perl|"
+fi
+
%build
unset QTDIR QTINC QTLIB
@@ -2299,6 +1852,7 @@ fi
\
-DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
-DBIN_INSTALL_DIR=%{tde_bindir} \
+ -DCONFIG_INSTALL_DIR="%{tde_confdir}" \
-DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
-DLIB_INSTALL_DIR=%{tde_libdir} \
-DSHARE_INSTALL_PREFIX=%{tde_datadir} \
@@ -2369,5 +1923,3 @@ popd
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 14.0.0-1
-- Initial release for TDE 14.0.0