summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdevelop/tdevelop.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdevelop/tdevelop.spec')
-rw-r--r--redhat/main/tdevelop/tdevelop.spec15
1 files changed, 15 insertions, 0 deletions
diff --git a/redhat/main/tdevelop/tdevelop.spec b/redhat/main/tdevelop/tdevelop.spec
index 7ee98f8d6..6839d6113 100644
--- a/redhat/main/tdevelop/tdevelop.spec
+++ b/redhat/main/tdevelop/tdevelop.spec
@@ -114,9 +114,15 @@ BuildRequires: libdb-devel
%else
# DB4 support
+%if 0%{?mgaversion} || 0%{?mdkversion}
+#BuildRequires: %{_lib}db4.8-devel
+%endif
%if 0%{?rhel} || 0%{?fedora}
BuildRequires: db4-devel
%endif
+%if 0%{?suse_version}
+BuildRequires: libdb-4_8-devel
+%endif
%endif
# FLEX support
@@ -148,6 +154,14 @@ BuildRequires: libacl-devel
# OPENSSL support
BuildRequires: openssl-devel
+# PYTHON support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 30 || 0%{?mgaversion} >= 8
+%global python python2
+%global __python python2
+%else
+%global __python python2
+%endif
+
%description
The TDevelop Integrated Development Environment provides many features
@@ -598,6 +612,7 @@ This package contains the libraries needed for the tdevelop programs.
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
+
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"