summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/themes/gtk-qt-engine/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/themes/gtk-qt-engine/debian/rules')
-rwxr-xr-xubuntu/_base/applications/themes/gtk-qt-engine/debian/rules34
1 files changed, 34 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/themes/gtk-qt-engine/debian/rules b/ubuntu/_base/applications/themes/gtk-qt-engine/debian/rules
new file mode 100755
index 000000000..8f250b682
--- /dev/null
+++ b/ubuntu/_base/applications/themes/gtk-qt-engine/debian/rules
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=/opt/trinity/lib:debian/tmp/opt/trinity/lib
+else
+LD_LIBRARY_PATH += :/opt/trinity/lib:debian/tmp/opt/trinity/lib
+endif
+export LD_LIBRARY_PATH
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DLIB_SUFFIX="" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" \
+ -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" \
+ -DAUTODETECT_QT_DIRS="ON" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DBUILD_ALL="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
+
+binary-install/gtk-qt-engine-trinity::
+ mkdir -p $(CURDIR)/debian/gtk-qt-engine-trinity/opt/trinity/share/kgtk/
+ cp -Rp $(CURDIR)/debian/.gtkrc-2.0-kde4 $(CURDIR)/debian/gtk-qt-engine-trinity/opt/trinity/share/kgtk/
+ cp -Rp $(CURDIR)/debian/.gtkrc-2.0-kde-kde4 $(CURDIR)/debian/gtk-qt-engine-trinity/opt/trinity/share/kgtk/
+ cp -Rp $(CURDIR)/debian/gtk-qt-engine.rc.sh $(CURDIR)/debian/gtk-qt-engine-trinity/opt/trinity/share/kgtk/