summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick_automake/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick_automake/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xubuntu/maverick_automake/dependencies/tqtinterface/debian/rules34
1 files changed, 0 insertions, 34 deletions
diff --git a/ubuntu/maverick_automake/dependencies/tqtinterface/debian/rules b/ubuntu/maverick_automake/dependencies/tqtinterface/debian/rules
deleted file mode 100755
index 79f24ff9a..000000000
--- a/ubuntu/maverick_automake/dependencies/tqtinterface/debian/rules
+++ /dev/null
@@ -1,34 +0,0 @@
-#! /usr/bin/make -f
-# see debian/rules file for kdesvn for cmake examples
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_KDE_APIDOX := yes
-
-version=Debian Package $(DEB_VERSION)
-DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/tde
-DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
-DEB_CONFIGURE_PREFIX := /opt/kde3
-DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_LIBRARY_PATH="/opt/kde3/lib" -DCMAKE_INCLUDE_PATH="/opt/kde3/include/tde" -DCMAKE_CXX_FLAGS="-I/opt/kde3/include/tde" -DCMAKE_LDFLAGS="-L/opt/kde3/lib"
-
-DEB_CONFIGURE_EXTRA_FLAGS := \
- --enable-mitshm --with-alsa --enable-dnotify --enable-inotify \
- --with-lua-includes=/usr/include/lua50 --prefix=/opt/kde3 \
- --with-distribution="Kubuntu (`lsb_release --codename --short`) $(DEB_VERSION)" --with-sudo-kdesu-backend
-
-DEB_FIXPERMS_EXCLUDE := \
- opt/kde3/bin/fileshareset \
- opt/kde3/bin/kgrantpty \
- opt/kde3/bin/kpac_dhcp_helper \
- opt/kde3/bin/start_kdeinit
-
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)