summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-12 12:56:37 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-12 12:56:37 +0200
commitef1942f65a25011fc41613900b0c6a91ae2f4763 (patch)
tree43e210a72c5463fbec675c2a757b1ca5c06d1168 /CMakeLists.txt
parentce02141dd4100636c9962f2830e0abef567b8030 (diff)
downloadtde-style-ia-ora-ef1942f65a25011fc41613900b0c6a91ae2f4763.tar.gz
tde-style-ia-ora-ef1942f65a25011fc41613900b0c6a91ae2f4763.zip
Add CMakeL10n rules.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c71865..145feb1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,12 @@ option( WITH_ALL_OPTIONS "Enable all optional support" OFF
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks
include( ConfigureChecks.cmake )
@@ -64,6 +70,11 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( src )
+##### other data ################################
+
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
+
##### write configure files
configure_file( config.h.cmake config.h @ONLY )