summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorMavridis Philippe <mavridisf@gmail.com>2024-03-10 17:53:54 +0200
committerMavridis Philippe <mavridisf@gmail.com>2024-03-10 17:53:54 +0200
commit7f408ad635a5e2a7829db68c19e51a295d55b9d1 (patch)
treea494c34a4c7a10d114a6b95fc4216f3eabce4e81 /client/Makefile.am
downloadtde-style-polyester-7f408ad635a5e2a7829db68c19e51a295d55b9d1.tar.gz
tde-style-polyester-7f408ad635a5e2a7829db68c19e51a295d55b9d1.zip
Imported from Pling
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
new file mode 100644
index 0000000..5b779ba
--- /dev/null
+++ b/client/Makefile.am
@@ -0,0 +1,19 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config images
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+METASOURCES = AUTO
+
+INCLUDES = $(all_includes) -I$(kde_includes)/kwin
+
+kwindir = $(kde_datadir)/kwin/
+kwin_DATA = polyester.desktop
+
+noinst_HEADERS = polyester.h buttons.h shadow.h ../style/misc.h
+
+kde_module_LTLIBRARIES = kwin3_polyester.la
+kwin3_polyester_la_SOURCES = polyester.cc shadow.cpp ../style/misc.cpp
+kwin3_polyester_la_LIBADD = $(kde_libraries)/libkdecorations.la
+kwin3_polyester_la_LDFLAGS = -module $(all_libraries) $(KDE_PLUGIN) -lkdecore