summaryrefslogtreecommitdiffstats
path: root/kate/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-15 20:12:47 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-15 20:12:47 +0200
commitcb8cda7bca532df21c02bc4d2bfd03387df7f852 (patch)
tree7f6b988c304024c9a45bccc2070790b65b95553e /kate/CMakeLists.txt
parent41f27d91571102626d9aae843adbe070fcb5aef3 (diff)
downloadtdeaddons-cb8cda7bca532df21c02bc4d2bfd03387df7f852.tar.gz
tdeaddons-cb8cda7bca532df21c02bc4d2bfd03387df7f852.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kate/CMakeLists.txt')
-rw-r--r--kate/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/kate/CMakeLists.txt b/kate/CMakeLists.txt
index 1506c26..46a42e4 100644
--- a/kate/CMakeLists.txt
+++ b/kate/CMakeLists.txt
@@ -31,4 +31,8 @@ add_subdirectory( katesort )
#### other data #################################
-install( FILES kate-plugins.desktop DESTINATION ${APPS_INSTALL_DIR}/.hidden )
+tde_create_translated_desktop(
+ SOURCE kate-plugins.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/.hidden
+ PO_DIR kate-plugins-desktops
+)