summaryrefslogtreecommitdiffstats
path: root/kate/filelistloader/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /kate/filelistloader/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kate/filelistloader/Makefile.am')
-rw-r--r--kate/filelistloader/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/kate/filelistloader/Makefile.am b/kate/filelistloader/Makefile.am
new file mode 100644
index 0000000..8b47569
--- /dev/null
+++ b/kate/filelistloader/Makefile.am
@@ -0,0 +1,34 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+#KDE_ICON = textfilter
+
+# Install this plugin in the KDE modules directory
+#kde_module_LTLIBRARIES = katefll_initplugin.la katefll_plugin.la
+kde_module_LTLIBRARIES = katefll_plugin.la
+
+# This is all standard. Remove the LIB_KHTML reference if you are not
+# using the KHTML Part
+#katefll_initplugin_la_SOURCES = katefll_initplugin.cpp
+#katefll_initplugin_la_LIBADD = -lkateinterfaces
+#katefll_initplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+katefll_plugin_la_SOURCES = katefll_plugin.cpp
+katefll_plugin_la_LIBADD = -lkateinterfaces
+katefll_plugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+# Install the .rc file in the Part's directory (in this case, the part
+# is KHTMLPart)
+pluginsdir = $(kde_datadir)/kate/plugins/katefll
+plugins_DATA = ui.rc
+
+#kde_services_DATA = katefll_initplugin.desktop katefll_plugin.desktop
+kde_services_DATA = katefll_plugin.desktop
+
+kdelnk_DATA = katefll.desktop
+kdelnkdir = $(kde_appsdir)/.hidden
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/katefll_initplugin.pot
+ $(XGETTEXT) *.cpp -o $(podir)/katefll_plugin.pot
+