summaryrefslogtreecommitdiffstats
path: root/kate/katesort/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2014-03-04 04:42:56 +0100
committerSlávek Banko <slavek.banko@axis.cz>2014-03-04 04:42:56 +0100
commit3e6828019fec8585b54d508f9c202106e6aa9311 (patch)
treef6f75845425a600b3072d5ce6fb7d935385d6809 /kate/katesort/CMakeLists.txt
parent462324fb8d4ff24c48599fb311aa1e26f9a4da53 (diff)
downloadtdeaddons-3e6828019fec8585b54d508f9c202106e6aa9311.tar.gz
tdeaddons-3e6828019fec8585b54d508f9c202106e6aa9311.zip
Integrate katesort as part of tdeaddons
Diffstat (limited to 'kate/katesort/CMakeLists.txt')
-rw-r--r--kate/katesort/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/kate/katesort/CMakeLists.txt b/kate/katesort/CMakeLists.txt
new file mode 100644
index 0000000..986e510
--- /dev/null
+++ b/kate/katesort/CMakeLists.txt
@@ -0,0 +1,38 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### katesortplugin (kpart) ##############
+
+tde_add_kpart( katesortplugin AUTOMOC
+ SOURCES plugin_sort.cpp sortdialog.cpp sortdialoglayout.ui
+ LINK kateinterfaces-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( katesort )
+
+
+##### other data ################################
+
+install( FILES plugin_sort.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kate/plugins/sort
+)
+
+install( FILES katesort.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)