summaryrefslogtreecommitdiffstats
path: root/konq-plugins/kuick/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /konq-plugins/kuick/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konq-plugins/kuick/Makefile.am')
-rw-r--r--konq-plugins/kuick/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/konq-plugins/kuick/Makefile.am b/konq-plugins/kuick/Makefile.am
new file mode 100644
index 0000000..f0cfa4c
--- /dev/null
+++ b/konq-plugins/kuick/Makefile.am
@@ -0,0 +1,26 @@
+SUBDIRS= kcmkuick
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = libkuickplugin.la
+
+# This is all standard. Remove the LIB_KHTML reference if you are not
+# using the KHTML Part
+libkuickplugin_la_SOURCES = kuick_plugin.cpp kdirmenu.cpp kmetamenu.cpp kimcontactmenu.cpp
+libkuickplugin_la_LIBADD = $(LIB_KABC) -lkimproxy -lkonq
+libkuickplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+pluginsdir = $(kde_servicesdir)
+plugins_DATA = kuick_plugin.desktop
+
+appsdir = $(kde_appsdir)/.hidden
+apps_DATA = kuickplugin.desktop
+
+# Install the .rc file in the Part's directory (in this case, the part
+# is KHTMLPart)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kuick_plugin.pot
+noinst_HEADERS = kimcontactmenu.h