summaryrefslogtreecommitdiffstats
path: root/konq-plugins/rsync/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-10-15 16:26:13 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-10-15 16:26:13 +0200
commit1a22301f46db807500b77119ae0132b9a3f876c5 (patch)
treeebf70d60bf7341685d1c4f6eb945e8d36baab9b2 /konq-plugins/rsync/CMakeLists.txt
parent6d9f2a4901eda474254a5d62a8c3701c2067ea58 (diff)
downloadtdeaddons-1a22301f46db807500b77119ae0132b9a3f876c5.tar.gz
tdeaddons-1a22301f46db807500b77119ae0132b9a3f876c5.zip
Initial cmake conversion
Diffstat (limited to 'konq-plugins/rsync/CMakeLists.txt')
-rw-r--r--konq-plugins/rsync/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/konq-plugins/rsync/CMakeLists.txt b/konq-plugins/rsync/CMakeLists.txt
new file mode 100644
index 0000000..697fd75
--- /dev/null
+++ b/konq-plugins/rsync/CMakeLists.txt
@@ -0,0 +1,51 @@
+#################################################
+#
+# (C) 2013 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### librsyncplugin (kpart) ####################
+
+tde_add_kpart( librsyncplugin AUTOMOC
+ SOURCES rsyncplugin.cpp
+ LINK konq-shared tdersync-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( )
+
+
+##### other data ################################
+
+install( FILES rsyncplugin.rc rsync_plugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqiconview/kpartplugins
+)
+
+install( FILES rsyncplugin.rc rsync_plugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqlistview/kpartplugins
+)
+
+install( FILES rsyncplugin.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/.hidden
+)