summaryrefslogtreecommitdiffstats
path: root/konq-plugins/searchbar/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /konq-plugins/searchbar/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konq-plugins/searchbar/Makefile.am')
-rw-r--r--konq-plugins/searchbar/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/konq-plugins/searchbar/Makefile.am b/konq-plugins/searchbar/Makefile.am
new file mode 100644
index 0000000..3a4c1b5
--- /dev/null
+++ b/konq-plugins/searchbar/Makefile.am
@@ -0,0 +1,21 @@
+SUBDIRS = icons
+
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = libsearchbarplugin.la
+
+libsearchbarplugin_la_SOURCES = searchbar.cpp
+libsearchbarplugin_la_LIBADD = $(LIB_KHTML)
+libsearchbarplugin_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+pluginsdir = $(kde_datadir)/konqueror/kpartplugins
+plugins_DATA = searchbar.rc searchbar.desktop
+
+install-data-local: $(srcdir)/../uninstall.desktop
+ $(mkinstalldirs) $(DESTDIR)$(pluginsdir)
+ $(INSTALL_DATA) $(srcdir)/../uninstall.desktop $(DESTDIR)$(pluginsdir)/searchbarplugin.desktop
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/searchbarplugin.pot