summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac2bbc2..3963ad8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,12 +41,13 @@ tde_setup_paths( )
##### optional stuff ############################
-option( WITH_ALL_OPTIONS "Enable all sane optional stuff" OFF )
-option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
-option( WITH_SDL "Enable SDL support" ${WITH_ALL_OPTIONS} )
-option( WITH_BERKELEY_DB "Enable Berkeley DB support" ${WITH_ALL_OPTIONS} )
-option( WITH_XMMS "Enable xmms support" OFF )
-option( WITH_TEST "Build tests" OFF )
+option( WITH_ALL_OPTIONS "Enable all sane optional stuff" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
+option( WITH_SDL "Enable SDL support" ${WITH_ALL_OPTIONS} )
+option( WITH_BERKELEY_DB "Enable Berkeley DB support" ${WITH_ALL_OPTIONS} )
+option( WITH_XMMS "Enable xmms support" OFF )
+option( WITH_TEST "Build tests" OFF )
##### options comments ##########################