summaryrefslogtreecommitdiffstats
path: root/kicker-applets/kbinaryclock/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kicker-applets/kbinaryclock/CMakeLists.txt')
-rw-r--r--kicker-applets/kbinaryclock/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/kicker-applets/kbinaryclock/CMakeLists.txt b/kicker-applets/kbinaryclock/CMakeLists.txt
new file mode 100644
index 0000000..3e2ff0a
--- /dev/null
+++ b/kicker-applets/kbinaryclock/CMakeLists.txt
@@ -0,0 +1,33 @@
+# This file is genereted by triniy-automake-cmake-convert script by Fat-Zer
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kbinaryclock_panelapplet (kpart) ##########
+
+tde_add_kpart( kbinaryclock_panelapplet AUTOMOC
+ SOURCES kbinaryclock.cpp settings.ui datepicker.cpp prefs.kcfgc
+ LINK tdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES kbinaryclock.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+)
+
+install( FILES kbinaryclock.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)