summaryrefslogtreecommitdiffstats
path: root/konq-plugins/webarchiver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'konq-plugins/webarchiver/CMakeLists.txt')
-rw-r--r--konq-plugins/webarchiver/CMakeLists.txt17
1 files changed, 14 insertions, 3 deletions
diff --git a/konq-plugins/webarchiver/CMakeLists.txt b/konq-plugins/webarchiver/CMakeLists.txt
index efe0480..38f1576 100644
--- a/konq-plugins/webarchiver/CMakeLists.txt
+++ b/konq-plugins/webarchiver/CMakeLists.txt
@@ -38,16 +38,27 @@ tde_install_icons( webarchiver )
##### other data ################################
-install( FILES plugin_webarchiver.rc plugin_webarchiver.desktop
+install(
+ FILES plugin_webarchiver.rc
DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
)
-install( FILES webarchivethumbnail.desktop
+tde_create_translated_desktop(
+ SOURCE plugin_webarchiver.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
+ PO_DIR konq-plugins-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE webarchivethumbnail.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR konq-plugins-desktops
)
-install( FILES plugin_webarchiver.desktop
+tde_create_translated_desktop(
+ SOURCE plugin_webarchiver.desktop
DESTINATION ${APPS_INSTALL_DIR}/.hidden
+ PO_DIR konq-plugins-desktops
)
install( FILES ../uninstall.desktop