summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/alarm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun-plugins/alarm/Makefile.am')
-rw-r--r--noatun-plugins/alarm/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/noatun-plugins/alarm/Makefile.am b/noatun-plugins/alarm/Makefile.am
new file mode 100644
index 0000000..8d2a928
--- /dev/null
+++ b/noatun-plugins/alarm/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES= -I$(kde_includes)/arts $(all_includes)
+kde_module_LTLIBRARIES = noatunwakeup.la
+
+noatunwakeup_la_SOURCES = wakeup.cpp \
+ kminutespinbox.cpp \
+ kpercentspinbox.cpp
+
+noatunwakeup_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatunwakeup_la_LIBADD = $(LIB_KFILE) -lnoatun -lm
+
+noatunwakeup_la_METASOURCES = AUTO
+
+noinst_HEADERS = wakeup.h \
+ kminutespinbox.h \
+ kpercentspinbox.h
+
+noatun_DATA = wakeup.plugin
+noatundir = $(kde_datadir)/noatun
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/wakeup.pot