summaryrefslogtreecommitdiffstats
path: root/twin-styles/smooth-blend/client/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-07 21:50:31 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-07 21:50:31 -0600
commite35f3fe53cd8df85d4fd04e49dfffbaeac971cdf (patch)
tree95836fc22de909b3b20dbf3fc3dea230e5e58e3b /twin-styles/smooth-blend/client/Makefile.am
parenta5355f151396be579eba5838c7d8d93a43362cd7 (diff)
downloadtdeartwork-e35f3fe53cd8df85d4fd04e49dfffbaeac971cdf.tar.gz
tdeartwork-e35f3fe53cd8df85d4fd04e49dfffbaeac971cdf.zip
Rename kwin to twin (Part 2 of 2)
Diffstat (limited to 'twin-styles/smooth-blend/client/Makefile.am')
-rw-r--r--twin-styles/smooth-blend/client/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/twin-styles/smooth-blend/client/Makefile.am b/twin-styles/smooth-blend/client/Makefile.am
new file mode 100644
index 00000000..056765d6
--- /dev/null
+++ b/twin-styles/smooth-blend/client/Makefile.am
@@ -0,0 +1,20 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = $(all_includes) -I$(kde_includes)/twin
+
+twindir = $(kde_datadir)/twin/
+twin_DATA = smoothblend.desktop
+
+noinst_HEADERS = smoothblend.h buttons.h
+
+kde_module_LTLIBRARIES = twin3_smoothblend.la
+twin3_smoothblend_la_SOURCES = smoothblend.cc
+twin3_smoothblend_la_LIBADD = -ltdecorations
+twin3_smoothblend_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -ltdecore -module $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx
+twin3_smoothblend_la_METASOURCES = AUTO
+
+DISTCLEANFILES = $(twin3_smoothblend_la_METASOURCES)