summaryrefslogtreecommitdiffstats
path: root/kcontrol/crypto/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/crypto/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/crypto/Makefile.am')
-rw-r--r--kcontrol/crypto/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kcontrol/crypto/Makefile.am b/kcontrol/crypto/Makefile.am
new file mode 100644
index 000000000..73a79653d
--- /dev/null
+++ b/kcontrol/crypto/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = $(all_includes) $(SSL_INCLUDES)
+kde_module_LTLIBRARIES = kcm_crypto.la
+
+kcm_crypto_la_SOURCES = crypto.cpp certexport.cpp kdatetimedlg.cpp
+
+AM_CXXFLAGS = $(CXXFLAGS) -DLIBDIR=$(libdir)
+
+kcm_crypto_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) $(SSL_LDFLAGS) -module -avoid-version -no-undefined
+kcm_crypto_la_LIBADD = -lkdeui $(LIB_KIO) $(LIBSSL)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = crypto.h certexport.h kdatetimedlg.h
+
+messages: rc.cpp
+ : > rc.cpp
+ $(XGETTEXT) $(kcm_crypto_la_SOURCES) *.h -o $(podir)/kcmcrypto.pot
+
+xdg_apps_DATA = crypto.desktop