summaryrefslogtreecommitdiffstats
path: root/kcontrol/konq/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /kcontrol/konq/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'kcontrol/konq/CMakeLists.txt')
-rw-r--r--kcontrol/konq/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/kcontrol/konq/CMakeLists.txt b/kcontrol/konq/CMakeLists.txt
index 3e99e5f27..019520a19 100644
--- a/kcontrol/konq/CMakeLists.txt
+++ b/kcontrol/konq/CMakeLists.txt
@@ -23,19 +23,24 @@ link_directories(
##### other data ################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
desktopbehavior.desktop desktop.desktop
desktoppath.desktop filebrowser.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+ PO_DIR kcontrol-desktops
+)
install( FILES
overlapping.png onlyone.png
DESTINATION ${DATA_INSTALL_DIR}/kcontrol/pics )
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
filebehavior.desktop fileappearance.desktop
filepreviews.desktop
- DESTINATION ${APPS_INSTALL_DIR}/.hidden )
+ DESTINATION ${APPS_INSTALL_DIR}/.hidden
+ PO_DIR kcontrol-desktops
+)
##### kcm_konq (module) #########################