summaryrefslogtreecommitdiffstats
path: root/kcontrol/tdefontinst/kcmfontinst/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-02-01 17:25:42 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-02-01 17:25:42 -0600
commiteba183d4de47093c6e44a99c8d7fe313aa2834c9 (patch)
tree53f8d1a08bd16668cb9040b2aaf9a041314b2003 /kcontrol/tdefontinst/kcmfontinst/CMakeLists.txt
parentf537c21b68e08f649b1b297bce8f3904603137e0 (diff)
downloadtdebase-eba183d4de47093c6e44a99c8d7fe313aa2834c9.tar.gz
tdebase-eba183d4de47093c6e44a99c8d7fe313aa2834c9.zip
Fix FTBFS
Diffstat (limited to 'kcontrol/tdefontinst/kcmfontinst/CMakeLists.txt')
-rw-r--r--kcontrol/tdefontinst/kcmfontinst/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/kcontrol/tdefontinst/kcmfontinst/CMakeLists.txt b/kcontrol/tdefontinst/kcmfontinst/CMakeLists.txt
new file mode 100644
index 000000000..b5a0da812
--- /dev/null
+++ b/kcontrol/tdefontinst/kcmfontinst/CMakeLists.txt
@@ -0,0 +1,40 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kcontrol/kfontinst/lib
+ ${CMAKE_SOURCE_DIR}/kcontrol/kfontinst/viewpart
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+tde_install_icons()
+install( FILES kcmfontinst.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+
+##### kcm_fontinst (module) #####################
+
+tde_add_kpart( kcm_fontinst AUTOMOC
+ SOURCES
+ KCmFontInst.cpp KFileFontIconView.cpp KFileFontView.cpp
+ PrintDialog.cpp SettingsDialog.cpp
+ LINK kfontinstprint-static kfontinst-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)