summaryrefslogtreecommitdiffstats
path: root/kdesktop/kwebdesktop/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /kdesktop/kwebdesktop/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kdesktop/kwebdesktop/CMakeLists.txt')
-rw-r--r--kdesktop/kwebdesktop/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/kdesktop/kwebdesktop/CMakeLists.txt b/kdesktop/kwebdesktop/CMakeLists.txt
index 741b8df34..34b84dc11 100644
--- a/kdesktop/kwebdesktop/CMakeLists.txt
+++ b/kdesktop/kwebdesktop/CMakeLists.txt
@@ -23,7 +23,11 @@ link_directories(
##### other data ################################
-install( FILES kwebdesktop.desktop DESTINATION ${DATA_INSTALL_DIR}/kdesktop/programs )
+tde_create_translated_desktop(
+ SOURCE kwebdesktop.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kdesktop/programs
+ PO_DIR kdesktop-desktops
+)
install( FILES kwebdesktop.kcfg DESTINATION ${KCFG_INSTALL_DIR} )