summaryrefslogtreecommitdiffstats
path: root/kfind/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /kfind/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'kfind/CMakeLists.txt')
-rw-r--r--kfind/CMakeLists.txt17
1 files changed, 14 insertions, 3 deletions
diff --git a/kfind/CMakeLists.txt b/kfind/CMakeLists.txt
index 4162c1319..aceaa738b 100644
--- a/kfind/CMakeLists.txt
+++ b/kfind/CMakeLists.txt
@@ -30,9 +30,20 @@ link_directories(
##### other data ################################
tde_install_icons( kfind )
-install( FILES Kfind.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES kfindpart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES findpart.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE Kfind.desktop
+ PO_DIR kfind-desktops
+)
+tde_create_translated_desktop(
+ SOURCE kfindpart.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kfind-desktops
+)
+tde_create_translated_desktop(
+ SOURCE findpart.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kfind-desktops
+)
##### libkfindpart (module) #####################