summaryrefslogtreecommitdiffstats
path: root/khelpcenter/searchhandlers/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /khelpcenter/searchhandlers/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'khelpcenter/searchhandlers/CMakeLists.txt')
-rw-r--r--khelpcenter/searchhandlers/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/khelpcenter/searchhandlers/CMakeLists.txt b/khelpcenter/searchhandlers/CMakeLists.txt
index 6c91e7a9c..8eb0e54b3 100644
--- a/khelpcenter/searchhandlers/CMakeLists.txt
+++ b/khelpcenter/searchhandlers/CMakeLists.txt
@@ -29,9 +29,12 @@ configure_file( khc_docbookdig.pl.in khc_docbookdig.pl @ONLY )
configure_file( khc_htdig.pl.in khc_htdig.pl @ONLY )
configure_file( khc_htsearch.pl.in khc_htsearch.pl @ONLY )
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
htdig.desktop man.desktop docbook.desktop
- DESTINATION ${DATA_INSTALL_DIR}/khelpcenter/searchhandlers )
+ DESTINATION ${DATA_INSTALL_DIR}/khelpcenter/searchhandlers
+ PO_DIR khelpcenter-desktops
+)
install( PROGRAMS
${CMAKE_CURRENT_BINARY_DIR}/khc_htdig.pl