summaryrefslogtreecommitdiffstats
path: root/konqueror/kttsplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /konqueror/kttsplugin/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'konqueror/kttsplugin/CMakeLists.txt')
-rw-r--r--konqueror/kttsplugin/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/konqueror/kttsplugin/CMakeLists.txt b/konqueror/kttsplugin/CMakeLists.txt
index fc3f409fe..a40509bc7 100644
--- a/konqueror/kttsplugin/CMakeLists.txt
+++ b/konqueror/kttsplugin/CMakeLists.txt
@@ -23,9 +23,16 @@ link_directories(
##### other data ################################
-install( FILES
- tdehtmlkttsd.rc tdehtmlkttsd.desktop
- DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins )
+tde_create_translated_desktop(
+ SOURCE tdehtmlkttsd.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
+ PO_DIR konqueror-desktops
+)
+
+install(
+ FILES tdehtmlkttsd.rc
+ DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
+)
##### libtdehtmlkttsdplugin (module) ##############