summaryrefslogtreecommitdiffstats
path: root/konqueror/remoteencodingplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /konqueror/remoteencodingplugin/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'konqueror/remoteencodingplugin/CMakeLists.txt')
-rw-r--r--konqueror/remoteencodingplugin/CMakeLists.txt20
1 files changed, 14 insertions, 6 deletions
diff --git a/konqueror/remoteencodingplugin/CMakeLists.txt b/konqueror/remoteencodingplugin/CMakeLists.txt
index 35c947858..a9e3b7f94 100644
--- a/konqueror/remoteencodingplugin/CMakeLists.txt
+++ b/konqueror/remoteencodingplugin/CMakeLists.txt
@@ -24,13 +24,21 @@ link_directories(
##### other data ################################
-install( FILES
- kremoteencodingplugin.rc kremoteencodingplugin.desktop
- DESTINATION ${DATA_INSTALL_DIR}/konqiconview/kpartplugins )
+tde_create_translated_desktop(
+ SOURCE kremoteencodingplugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqiconview/kpartplugins
+ PO_DIR konqueror-desktops
+)
+
+install(
+ FILES kremoteencodingplugin.rc
+ DESTINATION ${DATA_INSTALL_DIR}/konqiconview/kpartplugins
+)
-install( FILES
- kremoteencodingplugin.rc kremoteencodingplugin.desktop
- DESTINATION ${DATA_INSTALL_DIR}/konqlistview/kpartplugins )
+install(
+ FILES kremoteencodingplugin.rc ${CMAKE_CURRENT_BINARY_DIR}/kremoteencodingplugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqlistview/kpartplugins
+)
##### konq_remoteencoding (module) ##############