summaryrefslogtreecommitdiffstats
path: root/konqueror/sidebar/test/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /konqueror/sidebar/test/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konqueror/sidebar/test/Makefile.am')
-rw-r--r--konqueror/sidebar/test/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/konqueror/sidebar/test/Makefile.am b/konqueror/sidebar/test/Makefile.am
new file mode 100644
index 000000000..ebaeff299
--- /dev/null
+++ b/konqueror/sidebar/test/Makefile.am
@@ -0,0 +1,23 @@
+# this has all of the subdirectories that make will recurse into. if
+# there are none, comment this out
+SUBDIRS = .
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = konqsidebartest.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = konq_sidebartest.la
+
+# the Part's source, library search path, and link libraries
+konq_sidebartest_la_SOURCES = konqsidebartest.cpp
+konq_sidebartest_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+konq_sidebartest_la_LIBADD = $(LIB_KPARTS) $(LIB_KIO) ../libkonqsidebarplugin.la
+
+# this is where the part's XML-GUI resource file goes
+partrcdir = $(kde_datadir)/konqsidebartng/entries
+partrc_DATA = test.desktop