summaryrefslogtreecommitdiffstats
path: root/ksplashml/pics/themes/TDE-Classic/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /ksplashml/pics/themes/TDE-Classic/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'ksplashml/pics/themes/TDE-Classic/CMakeLists.txt')
-rw-r--r--ksplashml/pics/themes/TDE-Classic/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/ksplashml/pics/themes/TDE-Classic/CMakeLists.txt b/ksplashml/pics/themes/TDE-Classic/CMakeLists.txt
index f2ed63cae..1d0c03357 100644
--- a/ksplashml/pics/themes/TDE-Classic/CMakeLists.txt
+++ b/ksplashml/pics/themes/TDE-Classic/CMakeLists.txt
@@ -11,7 +11,15 @@
add_subdirectory( locolor )
-install( FILES
- Theme.rc Preview.png splash_active_bar.png splash_bottom.png
+tde_create_translated_desktop(
+ SOURCE Theme.rc
+ DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/TDE-Classic
+ PO_DIR ksplash-themes
+)
+
+install(
+ FILES
+ Preview.png splash_active_bar.png splash_bottom.png
splash_inactive_bar.png splash_top.png
- DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/TDE-Classic )
+ DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/TDE-Classic
+)