summaryrefslogtreecommitdiffstats
path: root/kxkb/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /kxkb/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kxkb/CMakeLists.txt')
-rw-r--r--kxkb/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/kxkb/CMakeLists.txt b/kxkb/CMakeLists.txt
index 872443229..b8bb14912 100644
--- a/kxkb/CMakeLists.txt
+++ b/kxkb/CMakeLists.txt
@@ -28,9 +28,18 @@ link_directories(
##### other data ################################
-install( FILES keyboard.desktop keyboard_layout.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE keyboard.desktop keyboard_layout.desktop
+ PO_DIR kxkb-desktops
+)
+
install( FILES kxkb_groups DESTINATION ${CONFIG_INSTALL_DIR} )
-install( FILES kxkb.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kxkb.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kxkb-desktops
+)
##### kcm_keyboard (module) #####################