summaryrefslogtreecommitdiffstats
path: root/libkonq/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /libkonq/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'libkonq/CMakeLists.txt')
-rw-r--r--libkonq/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/libkonq/CMakeLists.txt b/libkonq/CMakeLists.txt
index 532e31d4d..9c8842785 100644
--- a/libkonq/CMakeLists.txt
+++ b/libkonq/CMakeLists.txt
@@ -48,8 +48,17 @@ install( FILES
##### other data ################################
-install( FILES directory_bookmarkbar.desktop DESTINATION ${DATA_INSTALL_DIR}/kbookmark )
-install( FILES konqpopupmenuplugin.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE directory_bookmarkbar.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kbookmark
+ PO_DIR libkonq-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE konqpopupmenuplugin.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR libkonq-desktops
+)
##### konq (shared lib) #########################